Support » Plugin: custom tables » [Plugin: custom tables] Adding new field fails

  • When I click on the “Add New Field” button, nothing happens. No new field is added to the page, it doesn’t hit the server, nothing. I tried this in Chrome for Mac, IE8 and Safari for Mac (thinking it might be a browser incompatability), but no difference in any of them. The javascript for insertField() looks correct, but I’m no expert.

    Anyone else seen this behavior? Maybe it’s an incompatibility with 3.4.2?


Viewing 5 replies - 1 through 5 (of 5 total)
  • This is in the free (“non-Premium”) version.

    Is it possible that the free version only allows one new column?

    More information:

    I tried this on two completely different platforms (Windows and an iPad), using Firefox and Safari for iPad, and the problem remains.

    This seems to either be a 3.4.2 incompatibility or a conflict with another plugin (I have about 20 installed). Tonight I’ll try it on a different site of mine to see if it still has problems when there are only a couple of plugins.

    Workaround: I used Adminer to go directly to the table wp_wct3 and added the fields manually. That seemed to get me past this issue, but I’d much rather get a fix for it and use the intended UI to add a field.

    It’s not a 3.4.2 thing. I got the same results on a clean 3.4.2 install. And it worked okay on 3.4.1, followed by an upgrade on that site to 3.4.2. So, it has to be a conflict with another plugin. I’m working through them now…

    Okay, the culprit is WordPress Admin Notepad. All sites I run that have this activated experience this problem. Deactivating it causes your plugin to add new fields just fine. I will disable WordPress Admin Notepad on the site I’m using your plugin with because I need yours more, but I’d still like to get a fix. 🙂

    For the record, the following plugins have been TESTED and WORK with this plugin:

    Contexture Page Security
    Cleverness To-Do List
    Contact Form
    DM Albums
    Email address protector
    Jetpack Lite
    Login Logout
    Online Backup
    SB Welcome Email
    Share Buttons
    Simple Press
    Simple Admin Notes
    Wordpress Poll
    WTI Like Post
    TDO mini Forms
    Vote It
    Vote It Up!
    Participants Database
    Mingle Forums
    AP Honey Pot
    Dashboard Admin Email
    Exclude Pages
    My Calendar
    My Link Order
    Recipe Database
    Session Manager
    WP Filebase
    WP Underground
    SM Sticky Clicky Star
    Pinterest Pin It
    Email Protector
    Drain Hole
    Document Repository
    Ajax Contact Form

    If I figure out what the conflict is, I’ll post again.


    For anyone using WordPress Admin Notes and having this conflict, I recommend Simple Admin Notes as an alternative. I prefer the first one, but the alternative is a good second place, and it has no conflicts with this plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: custom tables] Adding new field fails’ is closed to new replies.