Support » Plugins and Hacks » [Plugin: Custom Post Type UI] Version 0.4.1 partially working with WP3 Beta 1

[Plugin: Custom Post Type UI] Version 0.4.1 partially working with WP3 Beta 1

  • Latest version of Custom Post Type UI is partially working work with my fresh install of WordPress 3 Beta 1.

    Although I can use the “Add New” option, if I try to edit a Post Type using “Manage Post Types”, I receive this error:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cpt_manage_cpt' was given in F:\Projects\wp3beta\wp-includes\plugin.php on line 395

    Any ideas?


Viewing 15 replies - 1 through 15 (of 37 total)
  • Not seeing that error when editing a post type. Exactly what option configuration did you have for that post type?

    Hi Michael. I can’t actually get into the necessary screen to tell you what settings the post type has: this error happens before you can see the post type. From memory though, I recall I accepted all the defaults, except for switching off some of the meta boxes (I think this was Comments, Revisions and Custom Fields). I didn’t create any taxonomies yet.

    It also doesn’t seem to make any difference what settings the post type has anyway: this error is also generated if you select “Manage Post Types” before you’ve even created a custom post type.

    Thanks for reporting. I’ll see if I can reproduce this error in my install.

    I tried to duplicate this error but couldn’t.

    What it looks like is that the custom post type wasn’t created in the first place. That would also account for the error you got when trying to access “Manage Post Types”. There weren’t any new types created so it threw up an error. (But, if that was the case, you should have gotten an error saying there were no new types created.)

    One thing to keep in mind is that you are working with a beta version of WordPress. Something which worked ok yesterday might not work after you upgrade to a newer build.

    I am author of GD Custom Posts And Taxonomies Tools plugin, that also implements interface for custom posts and taxonomies. And I am experimenting daily with each WordPress 3.0 iteration. Some versions of WP break custom post types, or add new things into the mix. My plugins latest version is 100% compatible with latest nightly build of WP 3.0. You might wanna give it a try.


    But, as ronbme said, WP is still in development, and I also expect that things will break from time to time until WP 3.0 is released as final. But, I will follow every change they make to it and change plugin accordingly.

    Tested and I can’t reproduce this error. Like others said there was probably a small bug in the nightly build. The code won’t break if no custom post types or custom taxonomies exist. It just won’t list anything

    I’m getting the same error as gambit37 using v0.5 of Custom Post Type UI and WP3.0 Beta 1.

    I get the following error as soon as i click on ‘Manage Post Types’

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘cpt_manage_cpt’ not found or invalid function name in [path removed]\wp-includes\plugin.php on line 395

    I do have custom post types created as the appear under the default screen .

    I also get a 404 if i click on ‘Edit’ for any of the custom post types that do exist.

    Are you both running WordPress locally? I wonder if that is causing the issue.

    I am running locally, using wamp. Any suggestions?

    I’m getting the same error on a production server using a 3.0 nightly downloaded today. Perhaps those without the error could try a vanilla install to see if they can replicate.

    smakdaddy, I’m running locally too.
    You might want to put a copy of jquery.min.js in the same directory with the plugin. Then you’ll need to edit the line in the plugin which references an external jquery.min.js file. Like this:

    // <script type=”text/javascript” src=”http://ajax.googleapis.com/ajax/libs/jquery/1.3.0/jquery.min.js”>
    <script type=”text/javascript” src=”jquery.min.js”>

    You can just comment out that first line and make a new line with what I have.

    That will allow you to view the “Advanced Options” for Custom Post Types and Taxonomies.

    Not sure why you are getting the “invalid function” error.

    mark8barnes, I just did a complete reinstall yesterday. Still not having that problem.

    One thing you and smakdaddy could check is to make sure that you have “administrator rights”. If you don’t, that is the problem.


    I’ve just upgraded to a nightly build of WP3 and also upgraded to Custom POst Type UI 0.5.1 — and I’m still getting this error. In fact, it comes up in other places now.

    I’m running locally using Wampserver 2.0 (MySQL 5.1.33, PHP 5.2.9-2) on WinXP.

    I’ll do a fresh install and see if there’s anything different.

    Fresh install makes no difference, I still get the original error:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cpt_manage_cpt' was given in F:\Projects\wp3beta\wp-includes\plugin.php on line 395

    Also, If I click EDIT next to a newly created custom post type (on the Custom Post Type main screen, the one with the Vimeo movie), I get a 404 Not found screen displayed in the 2010 theme (even though the URL is still showing I’m in the backend)

    If I try to delete a post type, I also get the original error.

    I have my permalinks set to /%posttype%/.

    Why do you have your permalinks set to /%posttype%/? I would set that to /%postname%/, or just use the default until you get things working.

    Also, do you have the network option, multi sites, set up on your build?

    If you’re getting a 404, it would seem that the path is not being found.


    Oops, I did in fact mean /%postname%/

    No multi site stuff set up at all. It’s a fresh out of the box install of WordPress 3 Beta 1 updated to yesterday’s nightly build. Nothing else added or changed. CPT UI is the only plugin active.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Plugin: Custom Post Type UI] Version 0.4.1 partially working with WP3 Beta 1’ is closed to new replies.