Custom Post Type UI
[resolved] Custom Post Type does not appear in admin menu WP 3.1 (3 posts)

  1. WebEndev
    Posted 5 years ago #

    When using Custom Post Type UI to register a new post type, it is not appearing in the admin menu as an option, and also not registering it.

    To make it work, I manually pasted the code (Get Code) into my functions.php file, and then it appeared and created the post type.

    I tried it several times, with several cpt names.

    Running latest version of the plugin, and WP 3.1.

    Any ideas on why it is not working correctly?

    Was working prior to CP 3.1 .....

  2. anmari
    Posted 5 years ago #

    Hi - I just tried this to debug a possible wp problem with custom post type capabilities (on wp 3.1 bleeding edge...)

    If I leave the custom post type capability as default 'post' then the custom post type appears in menu. (see advanced options in ui)

    If I change it to a custom name (eg: same as post type) then it does NOT appear in the menu.

    I think this may be due to
    either -
    1) a role thing may be the custom capability needs to be added to a role (I have a programmatically created post type and added the capability to admin and editor) or
    2) problem with wp "current user can" check rather than a plugin problem.

  3. anmari
    Posted 5 years ago #

    Me again - I got the custom post types to appear in menu with custom capability, by adding manually using 'members' plugin


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Post Type UI
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic