Custom Post Type UI
[resolved] Can taxonomy "type" cause conflict with media library? (12 posts)

  1. slobizman
    Posted 4 years ago #

    Someone else in the WP forum had a similar issue I am having, But his resolution doesn't work for me. It involves creating a taxonomy named "type". He and others in the thread discovered that there was a conflict with using that for the name of the taxonomy. The problem it caused was with looking at files in the WP media library. He deleted the taxonomy and media library started working again.

    I am having a similar issue with the media library, in that a search will show nothing. As such, I am unable to select any file in the media library. And I also use Custom Post Types UI plugin, and I also had a taxonomy named "type". Unlike him, when I deleted the taxonomy, it did not resolve the issues. I've also deactivated every plugin and it still does it.

    I have since recreated the a new taxonomy named listing_type. But I actually created "listing_type" before deleting "type" which is making me wonder if any taxonomy name with the letters "type" in them could cause a problem. Anyone know?

    Other than that, I'm wondering if there is something "left over" in the database with "type" in it that I should hunt down and delete. I haven't seen anything.

    Does anyone have any ideas that might help?


  2. slobizman
    Posted 4 years ago #

    Any ideas at all?

  3. Trevor Gehman
    Posted 3 years ago #

    I just went through this, and YES, it is definitely due to a conflict with the custom taxonomy called "type".

    The reason you're having trouble is if you created any entries in the "type" category, they are still in the database, even if you unregistered/deleted the custom taxonomy.

    Here's the steps I took that solved it:

    1. Delete the "type" taxonomy and create a new one using a different name. I used "property_type" and "article_type" and they work fine.

    2. Download plugin WP-DBManager to run an SQL query, and run this one:
    UPDATE wp_term_taxonomy SET taxonomy = '<new taxonomy name>' WHERE taxonomy = 'type'
    SOURCE: http://wordpress.stackexchange.com/questions/1037/renaming-custom-post-types-and-taxonomies

    That's it! Problem solved.

  4. iversoncru
    Posted 3 years ago #

    i have the same problem, but i do not have a taxonomy called 'type'

  5. Michael Beckwith
    Plugin Author

    Posted 3 years ago #

    We don't have cpt/taxonomy moving capabilities built in to our plugin, so renaming the slugs for either one will actually create a new one instead. We're aware of the issue, but we're not sure we want to build this in still. Best bet at the moment is to use what trevorgehman suggested above.

  6. iversoncru
    Posted 3 years ago #

    when i go to my database, i check the table "wp_term_taxonomy", and these are the taxonomies that i have:

    home page
    contact page
    about us page
    booking page

    is any of these taxonomies a problem?
    thanks a lot in advanced!!

  7. iversoncru
    Posted 3 years ago #

    i have realized a new thing.

    I created 5 custom post types, and 3-4 categories for each custom post type. I have just realised that some categories are called the same in different custom post type

    For instance:
    the custom post types "Home page" and "Contact page" both have a category called "bottom".

    Is these causing trouble? What do you think?

    thanks for your time!

  8. iversoncru
    Posted 3 years ago #

    well... i have deleted all the custom post types, and all the categories inside, went to the database and made sure there was no taxonomy or category after deleting.
    I create them all again, 2 custom post types and 4 categories in each paying attention to the slugs, nothing is called type or repeated.
    And still the same problem.
    any ideas?

  9. Michael Beckwith
    Plugin Author

    Posted 3 years ago #

    One thing that I noticed right away with your taxonomies is the fact that they have spaces in them. Meanwhile if you look at the ones WP does by default, they are either one word or they have an underscore in place of the space. I'm going to urge trying them without spaces and see if that clears up any issues. If you still are then I'll have to dig in deeper.

  10. iversoncru
    Posted 3 years ago #

    thanks for the idea! lol, didnt think of it!
    i let you know if i get it to work after remover spaces.

    thanks you very much

  11. iversoncru
    Posted 3 years ago #

    well, i was too desperate with the problem that i reinstalled wrodpress again. Version 3.5.2.

    Even before install Custom Post Type UI plugin again, the Media library is broken (I even created a new database to avoid problems)

    So the issue is not with the puglin; and apparently it is a problem with version 3.5.2 of wordpress :(

  12. Michael Beckwith
    Plugin Author

    Posted 3 years ago #

    Hopefully you get it resolved, though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Post Type UI
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.