Support » Plugin: Custom Post Permalinks » [Plugin: Custom Post Permalinks] Archives are not created

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author John P. Bloch


    Use %post_type% instead of just something. Plain text means nothing to the rewrite engine. You have to have rewrite tags to insert meaningful data into the structure. Your current permalink (except for single views) is basically telling WordPress to get your posts’ archives because you don’t have %post_type% anchoring the whole structure telling WP to look for that post type.

    By reading documentation on various places (repository, your blog, plugin’s settings), I didn’t conclude that permalink structure for custom post type needs to start with %post_type%.

    Anyway, I tried various changes, and although some things started to work, neither made everything to work.

    • /%post_type%/blog/%year%/%monthnum%/%something_post%/ – it made month and year archives work, but when I access I get a blank page; some notices: regularly redirects to, and works
    • since my custom post type has underscore in name, I tried with 'slug' => 'something', under rewrite in register_post_type; it did make something instead of post_type but still didn’t work (as above), plus I got a blank page when i go to, which is standard WordPress page.
    • when I tried to change blog with anything, in both above cases everything was the same, so it wasn’t problem with use of blog (which is already used for standard posts)

    Any idea on a way to achieve what I want, or that is impossible?


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Custom Post Permalinks] Archives are not created’ is closed to new replies.