Custom Permalinks
Stop working with WordPress 3.1? (4 posts)

  1. justpaulo
    Posted 5 years ago #

    I love this plugin, but now with the WordPress 3.1 update the permalinks of the categories stop working... Why? its just me with this problem?


  2. wookiecalling
    Posted 5 years ago #

    Hey there Justpaulo,
    Had the same problem as you did, managed fixing it this way..

    1. Disable ALL plugins
    2. Log into your server via sFTP/SSH/FTP and find your .htaccess file in the directory of the wordpress installation.
    4. rename or back up
    5. Go back to wp-admin and visit your permalinks page. enable custom permalinks with /%postname%/
    6. reactivate plugins

    This seemed to fix the issues I was having with permalinks.

  3. Hamster69
    Posted 5 years ago #

    Custom Permalinks stopped working for me too upon upgrade to 3.1. Found that differences in the permalink code in wp-includes/canonical.php were the problem, specifically the section of code beginning with

    // These tests give us a WP-generated permalink

    and ending before

    * Attempts to guess correct post based on query vars.

    Copying the code from that section found in the previous upgrade of WordPress wp-includes/canonical.php and pasting it into the WordPress 3.1 wp-includes/canonical.php fixed the problem. I now have a full clean, working WordPress 3.1 install, save for this one edit, and all my plugins function correctly, Custom Permalinks works perfectly.

    While I wouldn't suggest just splicing code for every upgrade (obviously, eventually, it'll cause more problems), maybe someone with more programming experience than me can look at the differences in the code in that section to see precisely what changed, and why it could have caused conflicts. I'm posting this because it gave me fits trying to fix the conflict and none of the other suggestions worked, but this code tweak did.

  4. ndayakar
    Posted 5 years ago #


    I too have the same problem. The custom permalinks plugin is not working with WordPress 3.1. I am getting the following message in safari when a custom permalink of a category archive is accessed.

    Too many redirects occurred trying to open “http://example.com/category/sub-category-2/”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

    @wookiecalling and @Hamster69,

    Tried your solutions, but it didn't resolve the issue. :-(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Permalinks
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic