Support » Plugin: Custom Field Suite » [Plugin: Custom Field Suite] PHP Fatal Error & Database problems

  • Resolved hughhempel

    (@hughhempel)


    I get the following errors in my PHP error logs:

    [13-Aug-2012 17:53:55] WordPress database error Table 'wp_GGP2012cfs_fields' already exists for query CREATE TABLE wp_GGP2012cfs_fields ( id INT unsigned not null auto_increment, name TEXT, label TEXT, type TEXT, instructions TEXT, post_id INT unsigned, parent_id INT unsigned default 0, weight INT unsigned, options TEXT, PRIMARY KEY (id), INDEX post_id_idx (post_id) ) DEFAULT CHARSET=utf8 made by require_once, require_once, require_once, require_once, do_action, call_user_func_array, Cfs->init, include, dbDelta 
    
    [13-Aug-2012 17:53:55] WordPress database error Table 'rareproj_GGP2012.wp_GGP2012cfs_rules' doesn't exist for query SELECT group_id, rule, value FROM wp_GGP2012cfs_rules made by require_once, require_once, require_once, require_once, do_action, call_user_func_array, Cfs->init, include [13-Aug-2012 18:21:43] PHP Fatal error: Call to a member function pre_save() on a non-object in /home1/rareproj/public_html/wp-content/plugins/custom-field-suite/core/api.php on line 528
    [13-Aug-2012 18:21:55] PHP Fatal error: Call to a member function pre_save() on a non-object in /home1/rareproj/public_html/wp-content/plugins/custom-field-suite/core/api.php on line 528
    [13-Aug-2012 18:38:45] PHP Fatal error: Call to a member function pre_save() on a non-object in /home1/rareproj/public_html/wp-content/plugins/custom-field-suite/core/api.php on line 528
    [13-Aug-2012 18:38:51] PHP Fatal error: Call to a member function pre_save() on a non-object in /home1/rareproj/public_html/wp-content/plugins/custom-field-suite/core/api.php on line 528

    The program seems to be “working”, but the errors are disconcerting…

    Any clues?

    Thanks again!

    http://wordpress.org/extend/plugins/custom-field-suite/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author logikal16

    (@logikal16)

    Hi,

    It looks like an old version of CFS was installed before, but wasn’t uninstalled correctly. If possible, try removing the cfs_rules, cfs_values, and cfs_fields tables, as well as the “cfs_version” option.

    DROP TABLE wp_GGP2012cfs_fields;
    DROP TABLE wp_GGP2012cfs_values;
    DROP TABLE wp_GGP2012cfs_rules;
    DELETE FROM wp_GGP2012options WHERE option_name = 'cfs_version' LIMIT 1;

    Once you do that, CFS will automatically perform a clean install.

    hughhempel

    (@hughhempel)

    This was a totally fresh install of CFS.

    There are 2 other possible explanations:

    1) I started out trying Advanced Custom Fields Plugin and abandoned the effort after bad experiences with compatibility. This does not explain the DB issue as ACF does not create a similar DB name

    2) I enabled/disabled/enabled CFS during a period of time where my system was a bit “unstable”…
    I don’t feel compelled to chase the issue since things appear to be working, but I thought you might want to know…

    I will report any future glitches…

    Plugin Author logikal16

    (@logikal16)

    Yeah, not sure. The cfs_rules table was dropped way back in CFS 1.2.0.

    Do please let me know if you run into other issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Custom Field Suite] PHP Fatal Error & Database problems’ is closed to new replies.