Support » Plugin: Custom Field Suite » [Plugin: Custom Field Suite] nothing displayed when I added new field group

  • Resolved szp895


    Hi everyone
    I am new to the custom field suite, I think I missed something in creating new field group.
    I followed the instruction to create a new group, only one field is called ‘name’, and showing on all the posts.
    and I can see the ‘name’ textbox is there, but when I filled a value, for example, I filled ‘Alan’ in the textbox, and click publish, there is nothing in the post view page!
    do I miss something ??? after publish, in the edit post page, the ‘name’ field still empty ! I think if I insert a value in ‘name’ field, the value should be there whatever I edit again or refresh…
    And, I checked database, the value has been inserted successful.

    how to I do ?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I mean, I create a new field group should be successful, but insert a value always can not be displayed..

    Plugin Author logikal16


    @szp895 – In order for fields to display on your site, you need to add some code in the appropriate template file.

    For example:

    <?php $global $cfs; ?>
    <?php echo $cfs->get('name'); ?>

    See the get() documentation for more information:

    Hi thanks for your quickly replying!
    I have tried to use shortcode exec php and custom field suite together to insert custom field in posts. but still does not work….
    I followed the instruction here
    I created a shortcode called [shop_info]
    global $cfs;
    echo $cfs->get(‘name’,$post_id);
    echo ” “.PHP_EOL;

    and then insert into every post, but does not work….in the video, it works. I tried to create other shortcode, it works.

    how can I do ?

    thanks man, I fixed that, um…actually I didnt fix anything, it is very strange that I use same code, same theme, everything same in my Mac XAMPP server, that does not work, whereas I try in my Windows server, it works!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Custom Field Suite] nothing displayed when I added new field group’ is closed to new replies.