Support » Plugin: Custom Field Suite » [Plugin: Custom Field Suite] "Array" being returned

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author logikal16

    (@logikal16)

    This is a bug caused by using a dash in the field name. I’ll try to have a patch out within the next few days, but a short-term fix would be to replace the dash with an underscore.

    You *may* also need to update the field names in wp_postmeta:

    UPDATE wp_postmeta SET meta_key = 'project_title' WHERE meta_key = 'project-title';

    Okay, I’ll replace the dash, but this is what I got back with your new line added:
    array(1) { [0]=> string(11) “Sallie Ford” }

    that fixed it! thank you.

    Plugin Author logikal16

    (@logikal16)

    Not a problem.

    Hope it’s okay to reply to the same thread. I get this problem with a select field only. I can’t have it anywhere on a page, not in the query, not outside of it. As soon as I change it to a text field, it works and I have other fields displaying as well. Otherwise it displays “array” only. I did add the global cfs as well.

    Tried this:
    <?php echo $cfs->get('situation_setting', get_the_ID()); ?>

    And this:

    <?php echo $cfs->get('situation'); ?>

    Both work if I change it from a select field to a text field.

    Any ideas? Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Custom Field Suite] "Array" being returned’ is closed to new replies.