Support » Plugin: Custom Field List Widget » [Plugin: Custom Field List Widget] not compatible with page widget

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ntm

    (@ntm)

    I will probably take a look at the problem at the weekend.

    Regards,
    Tim

    Plugin Author ntm

    (@ntm)

    Hi I have installed the WP Page Widget plugin and encountered this error while trying add the Custom Field List Widget to a sidebar of a post.

    Drag widgets here to remove them from the sidebar but keep their settings.

    Fatal error: Call to a member function get_settings() on a non-object in […]\wp-content\plugins\wp-page-widget\wp-page-widgets.php on line 449

    This message is related to an error which occurred in the WP Page Widget plugin. I’m not a hundred percent sure but this maybe has something to do with the fact that the Custom Field List Widget uses still the old Multi Widgets API of WP. This usually no problem and still works in WP 3.3.x and the WP-own sidebars.

    I will probably update my plugin soon.

    But it seems that the WP Page Widget does not take it into account that some widgets may need custom Javascripts to work correctly and own CSS definitions to look good. It seems that it does not import the scripts and styles of such widgets on the page with the editor where you can customize the sidebars for a post. I have notices this because I’m using further plugins which need these things. You may compare the <head> section of the source code of the editor and the widgets page.
    This is something which an update to the newer Multi Widget API would fix.
    I guess that the developers of WP Page Widget need to make some modification too to make this all work. (Or am I wrong here?)

    Tim

    NgaVuThanh

    (@ngavuthanh)

    Dear all,
    Thank you for reporting we will check.
    Best regards,
    Nga Vu Thanh [ Signature moderated. ]

    Dear all,
    We have fixed to supported this plugin.
    Please download latest version and try again.
    Best regards,
    Nga Vu Thanh [ Signature moderated. ]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Custom Field List Widget] not compatible with page widget’ is closed to new replies.