WordPress.org

Support

Support » Plugins and Hacks » Custom Content Types » [Resolved] [Plugin: Custom Content Types] Plugin could not be activated because it triggered a fatal error…

[Resolved] [Plugin: Custom Content Types] Plugin could not be activated because it triggered a fatal error…

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ooeygui

    @ooeygui

    Thanks, I’ll take a look at this asap

    Any update? I’m getting this as well with a new install of WP 3.0.1 on WAMP.

    You gotta stop using php short tags. Always use the full “<?php” tag, NOT “<?”, otherwise your plugin will be condemned to the trash heap by anyone who must deploy it on a server that has short tags disabled.

    Parse error: syntax error, unexpected $end in /path/to/wordpress3/html/wp-content/plugins/custom-content-types/_include/class.wp-plugins.php on line 463

    Plugin Author ooeygui

    @ooeygui

    fireproofsocks — Lol, this has been fixed.

    Are you sure? I have got the same error, and see there is lots of <?=plugins_url() and such throughout the plugin. I have changed all the php tags to the full version, which very almost works – I can install it, but now it will not let me save any new content types – and there isn’t any text on the submit button. It just refreshed the page when I press it.

    Maybe I am looking at a previous version or something?

    ooeygui — what version of PHP are you using? And do you have full errors being printed and short-tags off? You may need to re-submit changes. The WP repo had some problems with updates, so maybe mrchristoph and others are seeing an older version.

    Hello,

    I am having the exact same error here. Is there anything I can do to resolve this on my end? Or has there been any developments since the last popst?

    Just a quick update. I manually changed the “<?” tags, and it managed to activate itself.

    I thought I would mention it as it might have been a publishing problem for the plugin.

    If any changes were submitted sometime from about 2 months ago to about 3 weeks ago, the WP repository did not update the plugin’s download link, so the SVN copy might have had updates, but the forward facing website did not. This was a major screwup in the repo … any developers may have thought that their changes were properly posted, but instead the changes somehow flew under WordPress’ radar.

    ooeygui, if you did submit changes, try re-submitting them and tagging a new version of your plugin.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: Custom Content Types] Plugin could not be activated because it triggered a fatal error…’ is closed to new replies.
Skip to toolbar