WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Custom Content Type Manager] WYSIWYG Doesnt Show Format Controls

[Plugin: Custom Content Type Manager] WYSIWYG Doesnt Show Format Controls

  • WebmistressM
    Member

    @webmistressm

    Hmm… it appears that while I can create a custom content field that is a formatted/wysiwyg box, Im still unable to actually use the controls.

    I created the field in my custom content type. When I add a post of that product type, I can enter in any sort of text I want within this WYSIWYG text field. However, the controls for formatting do not show up.

    I did check and see if the user Im logged in with has its setting set to “disable visual editor” in case that was the problem. Seems that doesnt matter.

    I did notice a place to add extra attributes (columns, rows, font size, etc..) which may be where I can set a “minimum” on it, according to the documentation. Would this let my format control show up?

    http://wordpress.org/extend/plugins/custom-content-type-manager/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor fireproofsocks
    Member

    @fireproofsocks

    Ah, I think I know what’s going on… does your content type have the main “Content” field enabled? If not, then WordPress hides the necessary javascript. There was a bug about this previously, and I fixed it for an earlier version of WP, but it seems it’s back with 3.2.

    Try editing your content type, going to the Fields tab, and checking the “content” field, and then see if your WYSIWYG field behaves as expected.

    WebmistressM
    Member

    @webmistressm

    Yup. Thats the problem. So, for now, I am gonna have to have the content field and this secondary field in order to get the WYSIWYG controls for my custom field.

    Plugin Contributor fireproofsocks
    Member

    @fireproofsocks

    I’m gonna file the bug for this… it looks like WP has changed how it implements the WYSIWYG, probably they’re trying to phase out the deprecated thickbox JS…

    Thanks for bringing it to my attention.

    WebmistressM
    Member

    @webmistressm

    You are welcome.

    Plugin Contributor fireproofsocks
    Member

    @fireproofsocks

    I fixed this. The fix will be available http://wpcctm.com/cctm-dev.zip

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Custom Content Type Manager] WYSIWYG Doesnt Show Format Controls’ is closed to new replies.