Custom Content Type Manager
[resolved] Relation field not working? (5 posts)

  1. miketurco
    Posted 3 years ago #

    I have two forms, lets call them Pets and Owners.

    An owner can have many pets. When I enter in a new pet, I want to be select the owner on the pet's page. I would like select the owner's name (while in the editing view). When I view the actual post on the front end, I want to display the owner's name together a link to the owner's page.

    So, two problems. One is that I can't get the relation field to work at all. Can you please tell me how to configure the screen such that I can use the Relation field?

    Secondly, I don't know that once this is working, whether what I want to do is actually possible. Is it?




  2. miketurco
    Posted 3 years ago #

    Oh, I should mention, I don't know much about PHP :/.

  3. miketurco
    Posted 3 years ago #

    I did get the custom field working. I deleted it and recreated it. Don't know what I did wrong in the first place, but its on me. The rest of my questions remain open, though. Thanks! - Mike

  4. miketurco
    Posted 3 years ago #

    OK, I have the second thing working :) I've been at it for two days so I'm really pleased. And of course, it came from your documentation.

    I added this to the custom template and it works:


    $post = get_custom_field('sales_customer_relationship:get_post');
    echo $post['company'];


  5. miketurco
    Posted 3 years ago #

    I am marking this as resolved. Hopefully this will help someone else.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Content Type Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic