Support » Plugin: Custom Content Type Manager » [Plugin: Custom Content Type Manager] Post Types vanish when moving website

  • Resolved Ian Price


    CCTM Version:


    Firstly many apologies if this has already been addressed, I have looked but haven;t been able to see anything, so…

    I have a “test” WP site on a linux based web server, but I decided to pull it down to work my my WAMP setup I have used for WordPress / Drupal before.

    On this test site I have created a few custom post types using CCTM, and made a few posts of these types.

    I exported the MySQL Database, and zipped the web files.

    I changed the URL bases in the SQL file before restoring locally to reflect the different URL, restored the database and the web app, and all seems well, except – my custom post types do not show on the left menu, and don’t seem to be accessible.

    The posts of the types are in the database, and the CCRM options entry is present, and seems to contain the correct info.

    The way I got it to work was to export my custom types off my live server “test” version, and then import thenm to my WAMP version.

    I don’t know if this will have any ill effects as the data already seesm to be there?

    Any help, suggestions or pointing me to what I looked over by mistake would be greatly appreciated.

    Thanks a lot


Viewing 9 replies - 1 through 9 (of 9 total)
  • (First post should have said CCTM, not CCRM – damn typing!!)

    I tried again, and the steps I used are:

    1) Backed up the database off my server

    2) Looked in the SQL for the CCTM field in the options table, and the value is all good, as it wwas on Live before backup.

    3) I replaced the URLs to represent my development environment.

    4) Checked the SQL file again, and all still okay.

    5) Imported the SQL file to a new database.

    6) Checked the table value – and it was still good.

    7) I backed up the entire web app, brought that down to development, changing only the connection string details to point to the database in (5).

    8) Logged in to admin, and at that point I checked the CCTm value in the options table – and it has reset to what seems to be a default value:
    All my definitions present before logging in to Admin, have vanished.

    This is what it defaulted to:
    {“export_info”:{“title”:”CCTM Site”,”author”:””,”url”:”http:\/\/localhost\/wpTest”,”template_url”:””,”description”:”This site was created in part using the Custom Content Type Manager”,”_timestamp_export”:1338388363,”_source_site”:”http:\/\/localhost\/wpTest”,”_charset”:”UTF-8″,”_language”:”en-US”,”_wp_version”:”3.3.2″,”_cctm_version”:””},”post_type_defs”:[],”custom_field_defs”:[]}

    Any help would be greatly appreciated.

    Plugin Contributor fireproofsocks


    Sorry for the delayed response, I haven’t been receiving notifications from WP.

    This is a problem caused by how WP stores values: it uses PHP serialize, which requires a character count. So if you update any of your options in the database, it tends to change the character counts, and ends up corrupting the serialized data.

    What you need to do is
    1. Export your CCTM definition file on the first server (under CCTM –> Tools)
    2. Migrate your site
    3. Import the .cctm.json file you exported in step #1 on the new server.

    See FAQ:!

    Thanks for your reply. That;s what I have been doing – just wanted to be sure it was all good before going to a Live site.

    Thanks very much – great work by the way, love it!


    Plugin Contributor fireproofsocks


    Glad that worked! I’m gonna mark this as resolved.

    What you need to do is
    1. Export your CCTM definition file on the first server (under CCTM –> Tools)
    2. Migrate your site
    3. Import the .cctm.json file you exported in step #1 on the new server.


    I’m experiencing a similar problem.
    When i migrated my site frov dev. to live – my custom post types vere gone.
    I did the three steps above and everything worked just fine.

    But after a couple of weeks my my post types vere gone again. So i did the same three steps once more – and everything showed up again.

    Today the same thing happened again.
    I noticed that i forgot to include the Template URL before exporting the json file. I don’t know if that makes any difference?

    What am i missing? I hope someone can help? 🙂

    Plugin Contributor fireproofsocks


    I need exact steps to reproduce a bug before I can fix it. I’m not sure what would cause your post-type’s to disappear. I’ve had a few people tell me that this has happened to them, but I haven’t been able to reproduce the problem.

    Thank you for your quick response.

    Actually i’m not quite sure how to reproduce the problem either.

    Do you need to know everything, from installing and setting up the plugin on my dev. site, to how i move it to live?

    Or is the moving part, in details, enough?

    Plugin Contributor fireproofsocks


    Basically, if I can’t see the site fail for myself, I can’t see the bug. This is standard bug-reporting: I need to be able to reproduce it, otherwise, I can’t fix it. The bug report should include enough information so that the bug can be reproduced. It’s assumed that the plugin is installed, but often there’s something important in the setup that affects the behavior. Generally, too much info is better than too little — people usually don’t include enough info. But it’s critical that you can reproduce the problem first — if you can’t reproduce it reliably, then chances are almost zero that I’ll be able to find it.

    Re moving the site, this is documented:!

    Disregard this post, I’ve worked out the problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Custom Content Type Manager] Post Types vanish when moving website’ is closed to new replies.