Support » Plugin: Custom Contact Forms » [Plugin: Custom Contact Forms] Incorrectly filled form error message not displaying correctly

  • Hello everyone,

    I’ve looked through the different topics but can’t find an answer to my issue. I am using travel blogger theme for a site and when a form is submitted incorrectly, the error messages are not displayed in the “page/post” area but in On the header image!!! I can’t seem to figure out the cause. Has anyone else seen such a situation? I need help….

    I am using WP 3.3.1 with Custom Contact Forms

    Thank you!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Taylor Lovett


    Post a link where the problem occurs if you want help.


    Wow… that’s Fast service.

    Just hit “Rejestój zespół” at the bottom

    Thank you!

    Plugin Author Taylor Lovett


    That’s strange. The errors are just inserted into the_content() hook. It has to do with how your theme works I’m sure. Try using the default theme and seeing if it works just as a test.


    Yeah, I tried with twenty-eleven and it works fine. This is disappointing in terms of themes. It seems the header is actually contained in the body section! I’ll see what they have to say.

    On a side note: Excellent plugin!

    Thank you!

    I am getting no error messages at all when I fail to fill out fields. Please have a look:

    I am having the same problem here. The error message appear in header area and it also remove Logo image from that position.

    You can find quick form on a right side of a website:



    I actually solved it! Took me a while but I did it. Are you using the next gen gallery to display anything (particularily in the header)?

    I was using the nextgen gallery to display the rotatin gimages.. BUT as tlovett1 mentioned (the errors are being inserted into “the_content() hook”. I went back and went through my code and found that the code I was using for the nextgen header was as follows:

    $showgallery = ‘[slideshow=1]’;
    $showgallery = apply_filters(‘the_content’, $showgallery );
    echo $showgallery;

    Now as we all can see… there’s “The_content”. That’s why it was throwing the error messages there. So I changed to code to:

    if (function_exists(“nggSlideshowWidget”))
    { nggSlideshowWidget(1,975,300); }

    1 = Gallery number
    975 = Width of images
    300 = height of images

    Works like a charm now!

    Go through your header.php code or index.php… see if there is any code that contains the_content hook in the header… change that and you’re all set.

    Good luck!

    Hi plato_1974,

    Yes, I am using NextGen Gallery Plugin and I’ve looked for such string in my template files, but I couldn’t find one. It might be parsed in some way since the template is very complicated and modular, I don’t know.

    Than I had a different approach thinking that if I disable NG Gallery plugin, it might help … but no success 🙁 – error message is still showing in header.

    Maybe You have some more ideas?

    I am having a similar issue with our blog. I created a form and when filled out incorrectly, the errors show up in our slideshow content instead of next to or inside the actual form fields.

    I don’t mean to hijack the thread, should I create a separate thread? It seems to be the same issue, although I’m not very good with php.

    The link to our site with the form is The password to access is contest , didn’t want to make it completely live and start it early with a buggy validation.

    This is the code from the theme that the plugin enters content at,

    <div class="entry-content">
    <?php   global $more; $more = 1;  the_content(); ?>

    Any ideas how I can go about to make the errors validate inside the form fields or next to them?

    I’ve found solution for my problem :)))

    There was a nice little plugin called “Content Blocks” causing the error message appearing in header. What I did was replacing the content from this plugin with a pure html code and everything was just perfect.

    Hope that this will help someone 😉

    I am having similar problems. No error messages are being shown for this form: We’re using version with WordPress 3.4.2 and the theme, Product. The success messages display fine and the emails get sent. The issue is the error messages only.

    I found the conflict. The plugin, Greg’s High Performance SEO, is snagging the output. I’ve disabled it for now.

    I am having a similar issue with the error message replacing the content of my page. I am using my form within a lightbox on the home page, and it is not an option for me to disable that plugin. Any way at all to get the error message to display in a popup like the success message? I’ve tried getting creative with my code to place the_content() hook inside my form lightbox, but it is not working. Anybody have some input?

    Check out the answer to the question, “Why am I seeing unexpected output…” in the FAQ for the plugin. By creating our own meta descriptions for the pages containing the forms, we were able to successfully coexist with both plugins.

    Thanks jdouglas. I eventually found a way to wrangle the css and do some widget trickery to achieve my goal. It will work for now. I appreciate your response and I have bookmarked the link for the future.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Custom Contact Forms] Incorrectly filled form error message not displaying correctly’ is closed to new replies.