WordPress.org

Ready to get started?Download WordPress

Forums

Custom Contact Forms
captcha not working , spam is getting throuch (11 posts)

  1. okolubos
    Blocked
    Posted 3 years ago #

    hi,

    using hostgator for hosting my sites and have many websites with this plugin for contacting customers. this captcha (number field) is too easy to go through and I am receiving way too many spam messages. on all my websites.

    Please , is there a way to fix it, or give the spammer harder way to go thru....
    thanks for help

    http://wordpress.org/extend/plugins/custom-contact-forms/

  2. kevinmorton
    Member
    Posted 3 years ago #

    I am now having the same problem since about a month ago, getting sometimes as many as 5 spam form submissions a day. The captcha from Custom Contact Forms is ineffective. It is also the same numbers on each individual form for every single page refresh. This is not how a captcha is supposed to work. Can the developers integrate re-captcha or something similarly effective for the next update?

    For a plugin that is so detailed and complete elsewhere, I was surprised to find this all-important weakness.

  3. cuibel
    Member
    Posted 3 years ago #

    Same here. I demand an explanation.

  4. hungrybadger
    Member
    Posted 3 years ago #

    Me too, I just installed Custom Contact Forms mainly for the captcha feature. The spammers are still getting through.

    Can anyone post a hack for adding a better captcha feature to CCF?

  5. cuibel
    Member
    Posted 3 years ago #

    I just switched to Contact Form 7, it's really easy, probably better actually.

  6. okolubos
    Blocked
    Posted 3 years ago #

    all plugins are usually work in progress. just the attitude of the creator needs some feedback, ...or?

  7. okolubos
    Blocked
    Posted 3 years ago #

    is here some programmer who found how to perhaps help taylor with the spam problem? I am not a programmer, but is it realy hard of resolving it, ? perhaps its just one line of coding.... ;o)

  8. omerts
    Member
    Posted 2 years ago #

    ok I figured it out... the plugin sets a captcha for each session in the server, meaning it will probably set a different one for each user, but after the session has started it will always stay the same.
    This is a quick fix:
    Go to the plugin's folder and open image.php
    Change the following lines:

    if (!$_SESSION[$captcha_name])
    	$_SESSION[$captcha_name] = $str;
    else
    	$str = $_SESSION[$captcha_name];

    to just
    $_SESSION[$captcha_name] = $str;

  9. nextstepmike
    Member
    Posted 2 years ago #

    Did this solve the issue of the spam for anyone?

  10. UnniKris
    Member
    Posted 2 years ago #

    Thanks omerts. The captcha now reloads every time.
    But i believe its not a complete solution, we need something like recaptcha.

  11. The Web Fix
    Member
    Posted 2 years ago #

    Your doing it all wrong. You do not need to edit any code to get this fixed. You need to go into the General Settings. On the Bottom left of the General Settings you will see the settings for "reCaptcha" click the link to register for free. You will get 2 keys to plug into those 2 fields.

    https://www.google.com/recaptcha/

    After you configure those fields, you can add the "reCaptcha" as an attached field when configuring your form.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic