Support » Plugin: Custom Admin Branding » [Plugin: Custom Admin Branding] v3.0.3 bug fix – 'has_cap' deprecation warning

  • — DESCRIPTION —
    Version 3.0.3 causes the following warning in WP 3.1:

    PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/html/blog/wp-includes/functions.php on line 3387

    — FIX —
    In custom_admin_branding.php, line 28, replace 8 with 'manage_options'

    Patch format:

    28c28
    < $custombranding_admin = add_options_page(‘Custom Admin Branding’, ‘Custom Admin Branding’, 8, ‘brandingoptions’, ‘admin_branding_options_page’);

    > $custombranding_admin = add_options_page(‘Custom Admin Branding’, ‘Custom Admin Branding’, ‘manage_options’, ‘brandingoptions’, ‘admin_branding_options_page’);

    http://wordpress.org/extend/plugins/custom-admin-branding/

  • The topic ‘[Plugin: Custom Admin Branding] v3.0.3 bug fix – 'has_cap' deprecation warning’ is closed to new replies.