Support » Plugin: Advanced Custom Fields: Extended » plugin create bug in panel for adding user in multisite

  • Resolved adrienmedia

    (@adrienmedia)


    Hi,

    The plugin “Advanced Custom Fields: Extended” created a bug in the panel for adding new users in multisit blog.

    Submit buttons are removed :

    Plugin one : https://ibb.co/ydxZZmF
    Plugin off : https://ibb.co/KzQ5pjP

    ### wp-core ###
    version: 5.6
    
    ### wp-active-theme ###
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.0 (latest version: 1.1)
    
    ### wp-plugins-active (1) ###
    
    Advanced Custom Fields PRO: version: 5.9.3, author: Elliot Condon, Mises à jour auto désactivées
    Advanced Custom Fields: Extended: version: 0.8.7.6, author: ACF Extended, Mises à jour auto désactivées

    Any ideas as to why this is happening and what to do to fix it?

    Cheers!

    P.S. Your plugin is so cool.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the feedback! I’ve added the fix to the todo list for the next patch. In the meantime you can disable the Enhanced UI module using the following code, this will fix the issue:

    add_action('acf/init', 'my_acfe_modules');
    function my_acfe_modules(){
        
        acf_update_setting('acfe/modules/ui', false);
        
    }
    

    See documentation: https://www.acf-extended.com/features/wordpress/enhanced-ui

    Sorry for the inconvenience.

    Regards.

    Thread Starter adrienmedia

    (@adrienmedia)

    thank you!

    awesome, came here for this exact same problem, good to know it is already known and will probably be fixed soon

    great job on the plugin!

    • This reply was modified 1 month, 3 weeks ago by renatobe.

    I’m definitely looking forward to this being fixed in the next release (would be nice to keep the default of having the enhanced UI.)

    As a workaround in the meantime (while keeping the enhanced UI), it appears that going to the Network Admin => Sites => *Go to the specific site you want* => Users (tab within the page; not the one in the left admin navigation) and then using the forms below the list of the users works as that’s unaffected by the enhanced UI.

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello Everyone,

    Just a small update on the upcoming patch. The next update takes a little bit longer as expected, because it’s quite ambitious and has many new features. I’m working full time on it in order to release it as soon as possible. Just a little more patience, we’re not too far away from release!

    In the meantime, here is an updated code to disable the Enhanced UI Module only on Multisite New User screen, so you can still enjoy it on other screens (Terms, User Edit, WP Settings…):

    add_action('acf/init', 'my_acfe_disable_enhanced_ui_multisite');
    function my_acfe_disable_enhanced_ui_multisite(){
    
        global $pagenow;
        
        // Disable Enhanced UI on Multisite New User Screen only
        if($pagenow === 'user-new.php' && is_multisite()){
    
            acf_update_setting('acfe/modules/ui', false);
    
        }
    
    }
    

    Sorry for the inconvenience.

    Regards.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.