WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Crayon Syntax Highlighter] The Requested content cannot be loaded Please try again later

[Resolved] [Plugin: Crayon Syntax Highlighter] The Requested content cannot be loaded Please try again later

  • Hi akarmenia,

    I’m about to start making my own theme in a dev environment that I’ve setup on my webhost, but for now I am using the default twentyeleven theme that comes with WordPress 3.4.2. I want to get all the plugins installed and working before I start the theme development. I installed Crayon 1.11 and then when I make a new post, and click the tag editor, I get the error:
    “The Requested content cannot be loaded Please try again later”

    and here’s the dump from chrome developer tools console:

    Uncaught TypeError: Cannot call method 'val' of null crayon_te.js:573
    window.CrayonTagEditor.base.resetSettings crayon_te.js:573
    window.CrayonTagEditor.base.showDialog crayon_te.js:198
    (anonymous function) /wordpress/wp-content/plugins/crayon-syntax-highlighter/util/tag-editor/crayon_tinymce.js?ver=349-21274:81
    n.create.execCommand wp-tinymce.php:2
    c.create.createButton.i.onclick wp-tinymce.php:2
    b.create.postRender wp-tinymce.php:2
    d.create.add.g wp-tinymce.php:2

    I looked at the post over here which seems to be similar, but it looks like you found the error and have put in the fix already.

    Do you have any ideas? If not, I can give you access to the sandbox environment where the error occurs if that helps.

    Thanks again for your support,

    Mike

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am having the same problem on updating from 1.11 to 1.12
    The crayon buton wont launch the code box in visual editor

    says

    The Requested content cannot be loaded Please try again later

    I checked the link above and

    require_once('../../crayon_wp.class.php');
    crayon_die_if_not_php($_GET['wp_load'], 'wp-load');
    require_once ($_GET['wp_load']);

    I tried to change it.. did not work.
    Then I reverted back to original.
    I clicked on visual editor tab and then back to html tab.
    Bingo! now it works as crazy as it sounds 🙂

    Having the same problem with the latest version in plain view, and the WYSIWYG <-> Plain view trick does the job.

    yeah.. switching them <–> does the trick… 🙂

    Plugin Author akarmenia

    @akarmenia

    What is dev commit ?

    Anyway, for me it’s still not working. Still get the “The Requested content cannot be loaded” message.
    like dtouch said, going back and forth betwenn visual and html does the trick but not always. Weird ! and annoying…

    I hope the creator can fix this because it’s a great plugin. Thanks for it.

    Plugin Author akarmenia

    @akarmenia

    commit as in a code submission on github. I’ve tested it under firefox and chrome, both load the tag editor in HTML and Visual mode regardless of which is opened first. Are you using 1.13.1?

    Yes, I’m using 1.13.1 and I work under firefox. I’ve used your plugin for over a year and I’ve only had this problem since the last version (or last few versions ? I’m not sure which one.

    Plugin Author akarmenia

    @akarmenia

    here’s html mode in ff: http://snag.gy/sOwlI.jpg
    could you send one?

    To me visual or html mode are called from 2 tabs on the WP editor. I have never seen the window that shows on your picture, akarmena. So I’m not sure what you are asking me… I’m lost here.

    Plugin Author akarmenia

    @akarmenia

    Are you using this method: http://ak.net84.net/projects/crayon-tag-editor/

    Well, I’d like to but no. Whenever I click on <> (visual) or Crayon (html), I get the message “The requested content cannot be loaded.
    Please try again later.”
    That’s why I never got the “tag editor” you were talking about.
    Maybe it’s because I use the plugin “Ultimate TinyMCE”? I don’t know.

    Anyway, don’t worry, I insert the tags manually in html view and it works that way. It’s fine for me.

    Thanks,
    Fran

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Crayon Syntax Highlighter] The Requested content cannot be loaded Please try again later’ is closed to new replies.