Support » Plugin: Crayon Syntax Highlighter » [Plugin: Crayon Syntax Highlighter] TeX support

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author akarmenia


    Thanks a lot, I’ll add it into the next version tomorrow!

    Realized there is a mistake on the display of my site. The correct regexes should be the following:

    COMMENT (?<!\\)%.*?$

    # Make math formulaes appear as Strings
    MATH:STRING ((?<!\\)\$\$.*?(?<!\\)\$\$)|((?<!\\)\$.*?(?<!\\)\$)|((?<!\\)\\\[.*?(?<!\\)\\\])

    STATEMENT (\\[\w]+)|(\\[‘`^”~=.$vuH][\w]?)

    SYMBOL (?<!\\)(?default)

    I corrected my blog post, but somehow, HTML comment marks keep popping up, changing the first ‘<!’ into ‘<!–‘ and adding a ‘–>’ at the end of block. Does this come from Crayon, as a failsafe for incorrect syntaxes?

    Thanks for the inclusion into the plugin!

    Plugin Author akarmenia


    Works for me here:

    It might be TinyMCE or perhaps a WordPress setting. Try using the Tag Editor while in HTML mode?

    Well I don’t know. I got some weird things even in HTML mode. Got through it by replacing < with <.

    Thanks anyway! 🙂

    (I noticed the \r\n are now visible at the end of commented lines in TeX mode, I’ll try to adapt the regex when I have time and will let you know if I can make better)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Crayon Syntax Highlighter] TeX support’ is closed to new replies.