Support » Plugin: Nutrition Facts Vitamins » Plugin Crashes Page

  • Hey Ruth,

    I’ve got to tell you, this is an amazing plugin and helps my readers understand their nutrition so much better and contributes to their well-being! I’ve used as many as 130 of the labels on a single page and that tells you how much I love this plugin! Thanks for making this and keeping it up to date.

    Unfortunately, it has crashed the only post I have it on, on my site. My website loads a completely blank white screen. The first time I encountered the blank page earlier today I tried opening the post on my WordPress admin and it opened to an error in the plugin on line 473 of the main nutrition facts vitamin PHP file.

    I then searched around for the error and realised that the error was mainly being caused to PHP 7.1+ users (although I’m not entirely sure if it was the exact same or just a similar issue). So I contacted my host and switched to PHP 7.0.18. It worked beautifully when the executive first changed it and I checked the site. But then a couple of hours later, I see that the page went down again, and was displaying as a blank white screen like before. Except this time, there was no error when I opened the post and I could still edit the post and even preview it.

    Disabling the plugin gets the page to start working normally again. Haven’t been able to wrap my head around what exactly the issue is and why it’s being caused. Would be absolutely wonderful if you could take a look in your spare time and give me a solution for this.

    URL (although, the plugin might be deactivated because it’s throwing a blank page):
    https://dietbros.com/fat-burning/the-ultimate-fat-burning-foods-list/

    Surprisingly though, I had made a duplicate of the page – with fewer food items being the only difference for some other testing purposes, and it displays perfectly fine there even now!

    Here’s the URL:
    https://dietbros.com/fat-burning/the-ultimate-fat-burning-foods-list-2/

    Could you please take a look and let me know what action I can take next to get this resolved because I absolutely love your plugin!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ruth Maude

    (@dandelionweb)

    I have tested the plugin on a dev site and it works for me.

    It is possible that it is conflicting with another plugin or your theme. I suggest that you push your site to a staging environment to go through the following steps:

    1. If you aren’t using a staging space, ensure you have a backup of your site in case there are any issues when disabling/enabling plugins or your theme
    2. Disable all plugins (except your this plugin), and switch to a default theme like Twenty Sixteen then verify the issue is resolved
    3. Re-enable your plugins one by one verifying if the issue is still occurring, and note which one causes it to break.
    4. If the issue isn’t caused by a plugin, switch back to your previous theme

    Let me know which plugin/theme causes the issue and I may be able to come up with a fix, but you’ll also need to contact the theme or plugin author and have them fix the issue.

    Hi Ruth,

    Thank you so much for the prompt response! After 6 hours of testing, breaking my site and what not I finally managed to figure out which other plugin is clashing with this plugin. Tablepress, a plugin used to create tables. When either, Nutrition Facts Vitamin or Tablepress are deactivated, the page loads perfectly fine.

    Here is the post I’m having issues with again:
    https://dietbros.com/fat-burning/the-ultimate-fat-burning-foods-list/

    A couple of things I don’t get though and are quite bewildering:
    1) As I stated earlier, a dupe post of the post with 50% of the content (foods) stripped out (compared to the original post) works perfectly well with the Tablepress plugin as well. When activated, the Tablepress plugin as well as the nutrition labels display perfectly well.

    2) Both the plugins have been running in harmony since they’ve been installed (for the last few months now) and there hasn’t been any update to the Tablepress plugin as well for the last 3 months. This issue has cropped up all of a sudden and I’m unsure what’s causing it when everything was running just fine up until now!

    What’s the next step that we have to take? Is there anything additional I can do or any additional information I can provide you with? Let me know what to do, Ruth.

    Again, I can’t thank you enough for taking the time out to address this issue. A lot of people are getting healthier thanks to you! 😀

    P.S. On a side note, I must say that the developer (Tobias) of Tablepress is super responsive as well and a question I had posted on his plugin support page was answered by him in a couple of hours!

    Plugin Author Ruth Maude

    (@dandelionweb)

    I’m sorry but I don’t have any time in the next week to look at this as I’m going to be away. I can try reaching out to some developer friends and see if anyone has time to check into it.

    That would be wonderful, Ruth! How can I stay in touch with them? Also, will be happy to follow-up once you’re back and have some time on your hands.

    I’ll also get in touch with Tobias side-by-side to get things moving and see if there’s anything he can do from his end.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin Crashes Page’ is closed to new replies.