Support » Plugin: WP Google Maps » Plugin Crashed Website, Now Not Working?!

  • Hello, I’m still having issues with the plugin still not working since a few weeks back when many others also experienced issues with an upgrade. Apparently this was due to an older version of PHP not being supported, as mentioned here: https://wordpress.org/support/topic/unexpected-t_string-pgooglemaps-php-on-line-2184/#post-10384827

    In that thread I commented a few weeks ago mentioning the map plugin crashing a website. Staff mentioned that updating PHP to something higher than 5.3 would fix the problem, and recommended 5.6 specifically. Well, I just checked and the PHP version is 5.6.32. Yet I’m still experiencing problems. I continue to receive the same following error: Plugin could not be activated because it triggered a fatal error.Parse error: syntax error, unexpected T_STRING in /home1/arcocapi/public_html/wp-content/plugins/wp-google-maps/wpGoogleMaps.php on line 539

    This is an inconvenience because the client requires the use of your particular maps plugin due to the way it functioned. Any other ideas? I find it very odd that plugins don’t have a way to let users know if/when they crash a website. Who knows how long the site was down before I became aware. If there are security concerns, then why not just auto disable the plugin, not crash the entire site? Also, I never updated the PHP, so I’m assuming it was never out of date to begin with. Since the solution seems to not apply in my case, do you have any other suggestions? I’ve already wasted hours trying to figure this out. Any help would be appreciated. Thanks.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author DylanAuty

    (@dylanauty)

    Hi @needforname,

    Thank you so much for your time, and my sincere apologies for the inconvenience caused by this.

    Perry did respond to your last response, however I believe he may just have missed you.

    Please find his response added below:

    Hi there

    I’m genuinely sorry to hear you’re experiencing this issue,

    Can you please double check that you are definitely running PHP version 5.6 and that there hasn’t been any delay in applying that setting?

    Line 539 is very straightforward:

    $wpgmza_google_maps_api_loader = new WPGMZA\GoogleMapsAPILoader();

    The only possible source of this error is the parser being unable to interpret the namespace WPGMZA\. Namespaces were introduced in 5.3, we officially support PHP 5.6 and above.

    As per the PHP groups documentation here we strongly recommend that you switch to 5.6, or better still 7.0 and above, as support has been completely dropped for versions below this (including security updates).

    We take every possible measure to ensure updates to our plugin won’t entirely crash sites and that repair over FTP doesn’t become necessary, and we do try to support deprecated versions of PHP for as long as reasonably possible, however we do need to drop support for deprecated software and take advantage of newer technology as PHP moves forward.

    Can you please check your PHP version using a phpinfo plugin or similar?

    As a more short term solution, could you possibly roll back to the last compatible version?

    Kind regards
    – Perry

    I hope this helps? We are eager to get this resolved for you.

    I understand this issue is quite frustrating, and I would like to assure you that we are working around the clock to get this resolved.

    Plugin Contributor NickDuncan

    (@nickduncan)

    Hi @needforname
    Has your issue been resolved? May I close this ticket?

    Hey Nick, I’ve upgraded the PHP to version 5.6 and am still receiving the following error:

    WPParse error: syntax error, unexpected T_STRING in /home1/arcocapi/public_html/wp-content/plugins/wp-google-maps/wpGoogleMaps.php on line 602

    I’ve created a new ticket since I’ve noticed re-opening old tickets don’t get prompt responses. I figure I’d re-open this ticket since the recommended solution has not worked. I’ve tried all 3 different variations of php 5.6 and all 3 php 7.0 options on Bluehost. The plugin still won’t activate due to the above error.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    I’m terribly sorry to hear this, begging your pardon for any inconvenience caused.

    The line causing this error is the following:

    $wpgmza_google_maps_api_loader = new WPGMZA\GoogleMapsAPILoader();

    The only way this can fail is if your PHP version doesn’t support namespaces, eg WPGMZA\ which have been supported since PHP 5.3

    Can you please either create a phpinfo file or use a phpinfo plugin to make absolutely sure the version switch has been applied?

    Can you please also confirm your ticket reference so that I may request details through there?

    Kind regards
    – Perry

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.