1. Jelle82
    Posted 3 years ago #


    First off: great plugin. Doing cool things with it.

    One thing that I can't get to work is clean urls with the custom post types I created with CPT-onomies. After creating custom post types with your plygin, I changed my settings to /%postname%/. And when I go to a post with this post type I get a 404. Could you look into this?

    Please say, if my questions is not clear.

    Thank you for your time.


  2. Rachel Carden
    Plugin Author

    Posted 3 years ago #

    Problems with permalinks can be tricky to solve because they can be caused by multiple factors. Have you tried the following suggestions?

    My custom post type and/or CPT-onomy archive page is not working
    If archive pages are enabled but are not working correctly, or are receiving a 404 error, it's probably the result of a rewrite or permalink error. Here are a few suggestions to get things working:

    • Double check "Has Archive Page" Make sure the archive pages are enabled.
    • Are pretty permalinks enabled? Archive pages will not work without pretty permalinks. Visit Settings->Permalinks and make sure anything but "Default" is selected.
    • Changing rewrite rules: Whenever rewrite settings are changed, the rules need to be "flushed" to make sure everything is in working order. Flush your rewrite rules by visiting Settings->Permalinks and clicking "Save Changes".

    If none of those solved your problem, can you send me a screenshot of the "Advanced Options" in the CPT-onomies settings for your custom post type?

  3. Jelle82
    Posted 3 years ago #

    Hi, thanks for your reply. Too bad, your susggestions didn't work. I would like to send you some screenshots. What is your e-mailadress?

  4. Rachel Carden
    Plugin Author

    Posted 3 years ago #

    Fill out my contact form and I'll get back to you pretty quick.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic