Support » Plugin: Countdown Timer » [Plugin: Countdown Timer] Fatal error withe upgrade

Viewing 15 replies - 1 through 15 (of 22 total)
  • Happened to me as well. Reinstalled the plugin and it works. However there are nonworking functions.

    Like clicking the “Automatically delete ‘One Time Events’ after they have occured?” to “yes” makes most of the options disappear, along with all the dates. Also, the “Countdown Time Display” options doesn’t do anything. Tried turning off seconds, and seconds are still shown..

    Thanks for your answer !

    It works ! but you’re right lot of bug in this version. But still a very good plugin!

    Thanks again bonzo01

    Plugin Author fergbrain


    @pixwell and @bonzo01:

    My apologies on the update issue. A few WP versions ago (3.1 to be precise, ), there was a change to how register_activation_hook works and it no longer fires on updates. I didn’t catch that change.

    I have implemented a fix in 3.0.1 that I believe will solve the update issue by doing a version check against the database and will fire the install action if it detects a lower version. This will properly run the update so the plugin works. As you have also found, the same can functionality can be accomplished by deactivating and reactivating the plugin, but why make people do more work?

    Plugin Author fergbrain


    @bonzo01: I’m not able to reproduce the issues about “Automatically delete ‘One Time Events’ after they have occured?” to “yes” makes most of the options disappear, along with all the dates.”

    Did this occur before or after you deactivated and reactivated the plugin?

    fergbrain: I got this issue after reinstalling the plugin(reinstalled because of the update error).

    I have used this plugin for a long time, however i’ve never tried the automatic delete function before, so I have no idea if it used to work on my site. After setting it to “yes” and saving everything in the settings page in the admin panel disappears, except for the tabs: resources and installation and usage notes. The “one time events” tab is also there, but it’s blank and so is the rest of the settings page. The widget however is still working and still has all the events in there, so it seems to just fuck up the settings page. Deactivating and reactivating doesn’t make any difference after this issue appears.

    Also, changing the looks(removing weeks, minutes, seconds etc.) doesn’t seem to work. Changing the settings doesn’t do anything.

    Plugin Author fergbrain


    @bonzo01: Take a look at the latest version, 3.0.1. I think I’ve fixed the issues you’re having. If not, please let me know what version of WP and PHP you’re using, along with a screenshot of what you see. Sorry for the problems guys 🙁

    Hmm, it went from bad to worse 😉 Was able to update the plugin through WP admin, and even though the plugin still worked it didn’t fix the issues im having.

    So I deactivated it and now i’m getting a fatal error when reactivating. Got the same error when I remove the plugin and reinstall it (3.0.1).

    “Fatal error: Using $this when not in object context in /home/gamerdlv/public_html/wp-content/plugins/countdown-timer/fergcorp_countdownTimer.php on line 1158”

    Using WP 3.4 and PHP 5.2.17.

    I posted the same issue @
    right about the same time 🙂

    I downgraded to 3.0 again and that works for the time being…

    I marked the plugin broken which redirected me to write a new post, hence why I didn’t saw this topic.

    Plugin Author fergbrain


    This is not my week.

    I can confirm the issue. I took a look at it this morning. As Beee pointed out, 3.0 does work and I am comfortable with saying that you can use 3.0.

    I’m not 100% sure why is throwing that error, but I’m working on understanding what the WordPress core is doing (it has to do with how WordPress activates settings for plugins that are using Classes, this is my first class…there were bound to be issues).

    In any event, I’ve pulled back the 3.0.1 release, so hopefully not too many people will be affected. Again, so sorry for this. I’m pretty embarrassed that I released code that is doing this.

    Uhm, I just found out something in 3.0

    I have seconds disabled on my countdown but they do show on (bottom right).

    Yeah I have the same issue with the “countdown time display”. You should look into that as well fergbrain 🙂 In 3.0 the settings for whether to show seconds, minutes, hours etc. doesn’t do anything.

    Plugin Author fergbrain


    Gentlemen: Hot off the press is a pre-release version of 3.0.2:

    If you wouldn’t mind taking a look at it and seeing if you have any issues, I would greatly appreciate it. I believe I have once and for all quashed the initialization bug no matter if you upgrade or activate.

    I’ve also found and quashed the bug relating to the issue of seconds being disabled or not.

    I’m going to bed now, but if you get a chance to test it in the seven hours (before 7am [-0700 GMT]), I’ll throw it up on the WordPres SVN.


    Seems to be working now, at least as a new install and activate. Wasn’t able to try updating. Also, disabling seconds (and whatever else you want) is now working properly 🙂

    I’ll try the “Automatically delete ‘One Time Events'” function later when I have some more time, since I had some issues with it in 3.0.

    Plugin Author fergbrain


    @bonzo01: I tested the delete one time events functionality and it’s been working for me. I released 3.0.2 yesterday, but if you end up having issues, please let me know!

    Thanks again for all your help!

    Yeah the “delete one time events” is still not working for me, even with 3.0.2. It’s not a big deal since I usually don’t use it anyway and it doesn’t seem like many others have this issue.

    But if you want to look into it anyway I posted a screenshot at tinypic. This is how my settings page in my admin panel looks after turning “delete one time events” on. What you see on the screenshot is all the way scrolled down, and all the tabs except for the infotabs are gone from the settings page. The widget still works though and all my events are still listed there, but as you can see i’m unable to add more or do any other changes unless I reinstall the plugin.

    As mentioned earlier, i’m using WP 3.4, PHP 5.2.17 and 3.0.2 version of the plugin.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Countdown Timer] Fatal error withe upgrade’ is closed to new replies.