• Resolved serfer5

    (@serfer5)


    Hi!

    Use your plugin on the website, updated to the last version of it, and got fatal error Uncaught Exception: Could not get plugin directory. All permisions of folders and files are 755 and 644.

    Can you help with that?

    Fatal error: Uncaught Exception: Could not get plugin directory in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/WordPressTools.php:82 Stack trace: #0 /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/WordPressTools.php(24): WordPressTools->getPluginDir() #1 /wp-content/plugins/cf7-sms-extension/cf7-sms-extension.php(143): WordPressTools->__construct('/wp-content/plu...') #2 /wp-content/plugins/cf7-sms-extension/cf7-sms-extension.php(149): kmcf7_sms_extension\KMCF7SEStart() #3 /wp-admin/includes/plugin.php(2318): include_once('/wp-content/plu...') #4 /wp-admin/plugins.php(192): plugin_sandbox_scrape('cf7-sms-extensi...') #5 {main} thrown in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/WordPressTools.php on line 82

    Now plugin is disabled

    • This topic was modified 8 months, 4 weeks ago by serfer5. Reason: add comment about using this plugin

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author kofimokome

    (@kofimokome)

    Hi,

    Sorry for the inconvenience. I am looking into the issue.

    Plugin Author kofimokome

    (@kofimokome)

    Are your plugins stored in a folder different from wp-content/plugins?

    Thread Starter serfer5

    (@serfer5)

    No, in /wp-content/plugins

    View post on imgur.com

    Plugin Author kofimokome

    (@kofimokome)

    ok. I will release an update soon

    Plugin Author kofimokome

    (@kofimokome)

    Please update the plugin and check if you still have issues. I see two possible reasons. If it does not still work for you, I will look at the second case.

    • This reply was modified 8 months, 4 weeks ago by kofimokome.
    Thread Starter serfer5

    (@serfer5)

    After update https://i.imgur.com/6Ncw08W.png

    Fatal error: Uncaught Exception: Could not get plugin directory in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMRouteManager.php:107 Stack trace: #0 /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMRouteManager.php(75): KMRouteManager->getPluginDir() #1 /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/WordPressTools.php(54): KMRouteManager->renderView(‘settings’, true) #2 /wp-content/plugins/cf7-sms-extension/core/CF7SmsExtension.php(324): WordPressTools->renderView(‘settings’) #3 /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMSubMenuPage.php(81): kmcf7_sms_extension\CF7SmsExtension->statusTabView(Array) #4 /wp-includes/class-wp-hook.php(310): KMSubMenuPage->show_tabs(”) #5 /wp-includes/class-wp-hook.php(334): WP_Hook->apply_filters(NULL, Array) #6 /wp-includes/plugin.php(517): WP_Hook->do_action(Array) #7 /wp-admin/admin.php(259): do_action(‘toplevel_page_k…’) #8 {main} thrown in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMRouteManager.php on line 107

    There has been a critical error on this website. Please check your site admin email inbox for instructions.

    Plugin Author kofimokome

    (@kofimokome)

    Thanks, this is my fault. I have fixed the issue.

    Please can you manually download and update the plugin from this link?

    https://drive.google.com/file/d/1HrHB5TlsDoJ-zAAj6kiUf4O2h3Fcdc9i/view?usp=sharing

    Just to be sure it works on your website before releasing the final update.

    Thread Starter serfer5

    (@serfer5)

    Still have some dificults – in tabs didn`t see any settings(just in SMS history all ok, screenshot below:

    View post on imgur.com

    Warning: include(//wp-content/plugins/cf7-sms-extension/settings.php): failed to open stream: No such file or directory in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMRouteManager.php on line 77

    Warning: include(): Failed opening ‘//wp-content/plugins/cf7-sms-extension/settings.php’ for inclusion (include_path=’.:/:/usr/local/php74/lib/pear’) in /wp-content/plugins/cf7-sms-extension/lib/wordpress_tools/KMRouteManager.php on line 77

    https://i.imgur.com/RyEjlXX.png – server info

    • This reply was modified 8 months, 4 weeks ago by serfer5.
    Plugin Author kofimokome

    (@kofimokome)

    Thanks for your patience.

    Please just deactivate the plugin. I’ll work on it over the weekend. I’ve not been able to reproduce the issues you are having on my end. I will analyse the screenshots you have sent and come up with a fix.

    once again thanks for your patience and sorry for the inconveniences.

    Plugin Author kofimokome

    (@kofimokome)

    if i need anything, I will get back to you

    Thread Starter serfer5

    (@serfer5)

    Thanks) will wait for fix)

    PS I tried donate You on ko-fi, also have some troubles with paypal from Ukraine, do You have another donate system?

    Plugin Author kofimokome

    (@kofimokome)

    Hi,

    I think I have found the issue, please try again one more time
    link => https://drive.google.com/file/d/1EBODfRSaaFdUR0qPmWfOtP7KRxXPy5yt/view?usp=sharing

    Plugin Author kofimokome

    (@kofimokome)

    For the donation, you can try this link => https://flutterwave.com/pay/kofimokomegxms

    Or you can pay for the pro version of this plugin.

    Thread Starter serfer5

    (@serfer5)

    Thanks! Working good!

    Plugin Author kofimokome

    (@kofimokome)

    Okay. Thanks for your help in resolving this issue. I will now release an official update.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.