Support » Plugin: SSL Zen - Free SSL Certificate & HTTPS Redirect for WordPress » Plugin could not be activated because it triggered a fatal error.

  • Resolved airdrummer

    (@airdrummer)


    Fatal error: Uncaught TypeError: Argument 1 passed to Freemius::get_api_user_scope_by_user() must be an instance of FS_User, bool given, called in ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php on line 22725 and defined in ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php:22739
    Stack trace:
    #0 ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php(22725): Freemius->get_api_user_scope_by_user(false)
    #1 ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php(22764): Freemius->get_api_user_scope(false)
    #2 ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php(19641): Freemius->get_current_or_network_user_api_scope()
    #3 ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php(11483): Freemius->_fetch_plugin_plans()
    #4 ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius. in ~/public_html/wp-content/plugins/ssl-zen/freemius/includes/class-freemius.php on line 22739

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor SSL Zen – Support

    (@sslzensupport)

    Hello @airdrummer,

    We have tried replicating the above scenario on our test server and the plugin updated fine. Kindly delete the old version of the plugin and install the latest version and let us know if the issue still persists.

    Thank you.

    Thread Starter airdrummer

    (@airdrummer)

    sorry, deleted/reinstalled, same fatal error

    > class-freemius.php on line 22739

    yoi! try factoring?

    • This reply was modified 3 months, 1 week ago by airdrummer.
    Thread Starter airdrummer

    (@airdrummer)

    & the error occurs on _activation_ not install/update

    Plugin Contributor SSL Zen – Support

    (@sslzensupport)

    Hello @airdrummer,

    Kindly deactivate the plugin and download freemius-fixer plugin from below link and follow the steps mentioned:
    https://github.com/Freemius/freemius-fixer/

    Once the issue is resolved, you can activate the plugin.

    This should help. Let us know if you still have any concerns.

    Thread Starter airdrummer

    (@airdrummer)

    thanx, that fixed it…apparently $this->_user was null in the call

    $this->get_api_user_scope_by_user( $this->_user );

    causing php to send false:

    Freemius->get_api_user_scope_by_user(false)

    ain’t php phun?-}

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.