WordPress.org

Forums

ThreeWP Broadcast
[resolved] Plugin could not be activated because it triggered a fatal error. (27 posts)

  1. alejandrofm
    Member
    Posted 2 years ago #

    I used a fresh install of wordpress v3.5.1 and ThreeWP Broadcast v1.19

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING in C:\xampp\htdocs\wordpress\wp-content\plugins\threewp-broadcast\plainview_sdk\db_aware_object.php on line 37

    Thanks.

    http://wordpress.org/extend/plugins/threewp-broadcast/

  2. DFC005
    Member
    Posted 2 years ago #

    Can't access wp-admin now after updating plugin.

  3. alejandrofm
    Member
    Posted 2 years ago #

    I recommend you to restore the previous version. Do you have a backup?

  4. DFC005
    Member
    Posted 2 years ago #

    Trying that right now.

  5. DFC005
    Member
    Posted 2 years ago #

    OK, restored to previous version and all is well again.

  6. edward mindreantre
    Member
    Posted 2 years ago #

    Install php v5.4 if possible.

  7. alejandrofm
    Member
    Posted 2 years ago #

    PHP v5.4 is now required.

  8. DFC005
    Member
    Posted 2 years ago #

    Right, well that might need to be mentioned before everyone goes and updates.

  9. edward mindreantre
    Member
    Posted 2 years ago #

    I've now put it in the readme. Suggestions as to where else I should put the text are welcomes.

  10. DFC005
    Member
    Posted 2 years ago #

    The changelog. That's generally what I read before installing.

    Great plugin by the way.

  11. edward mindreantre
    Member
    Posted 2 years ago #

    Already in the changelog. Let's hope people read it before trying to upgrade...

  12. alejandrofm
    Member
    Posted 2 years ago #

    Great work :)

  13. edward mindreantre
    Member
    Posted 2 years ago #

    I've had a look into the SDK and traits are used for db_aware_objects (not used) and tables (used).

    Since the table class is _very_ useful and much easier to use than manually coding tables, I can't see reverting Broadcast back to 1.18, therefore the SDK stays.

    So my question to you guys is: what do y'all suggest?

  14. chrisruggia
    Member
    Posted 2 years ago #

    I'd suggest offering a legacy download link for 1.18, at least for a while until PHP 5.4 is more widely adopted by hosts.

    That way people (like me) who didn't notice the 5.4 requirement can more easily step back one version if they don't have up-to-date backup files. I had updated automatically a few times, so for now I'm using the backup version I had on my machine, which was 1.11.

    My client's site that uses your plugin is at media temple, which only offers 5.3.15 for their (gs) hosting.

    You might possibly consider editing the notice in the changelog to be a bit more prominent (maybe something like "WARNING: This version requires PHP 5.4 and will not activate without it!").

    Thanks VERY MUCH for your work providing this plugin. It's been a great help for my client and their staff.

  15. edward mindreantre
    Member
    Posted 2 years ago #

  16. chrisruggia
    Member
    Posted 2 years ago #

    THANKS!

  17. dhuet2001
    Member
    Posted 1 year ago #

    I have to same problem to and the 1.18 download is the 1.19. Do you habe another link?

  18. edward mindreantre
    Member
    Posted 1 year ago #

    Link should be fixed now.

    File should be 474 215 bytes big.

  19. opsman
    Member
    Posted 1 year ago #

    Will the 1.18 version stay compatible with future versions of WordPress, as my client uses his own server and updating PHP maybe a problem with some older scripts they have.

    Or is there a way to install a different PHP version on the one website?

  20. edward mindreantre
    Member
    Posted 1 year ago #

    1.18 is legacy = will not be modified (nor supported) in the future.

  21. tezza71
    Member
    Posted 1 year ago #

    The latest plugin update is still breaking people's wordpress admin consoles.

  22. tezza71
    Member
    Posted 1 year ago #

    I don't see why the plugin can't detect which PHP version it's running and actually handle the exceptional condition with a civilized error saying that the current version of the plugin is not supported with that version of PHP. Instead is just cripples the user's WP installation and leaves them to play detective.

    Just saying.

  23. edward mindreantre
    Member
    Posted 1 year ago #

    tezza: You are welcome to send me a patch that does what you require.

  24. akshitha
    Member
    Posted 1 year ago #

    Parse error: syntax error, unexpected '[' in E:\zend\emp\wp-content\plugins\threewp-broadcast\ThreeWP_Broadcast.php on line 215

    wordpress version 3.6.1

    wats up the problem? please reply as soon as possible

  25. andrrs
    Member
    Posted 1 year ago #

    Can you get the link to threewp-broadcast_v1.18.zip up and working? I get the Parse error.

  26. edward_plainview
    Member
    Plugin Author

    Posted 1 year ago #

  27. edward_plainview
    Member
    Plugin Author

    Posted 1 year ago #

    akshitha: what version of PHP are you using?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.