I'd suggest offering a legacy download link for 1.18, at least for a while until PHP 5.4 is more widely adopted by hosts.
That way people (like me) who didn't notice the 5.4 requirement can more easily step back one version if they don't have up-to-date backup files. I had updated automatically a few times, so for now I'm using the backup version I had on my machine, which was 1.11.
My client's site that uses your plugin is at media temple, which only offers 5.3.15 for their (gs) hosting.
You might possibly consider editing the notice in the changelog to be a bit more prominent (maybe something like "WARNING: This version requires PHP 5.4 and will not activate without it!").
Thanks VERY MUCH for your work providing this plugin. It's been a great help for my client and their staff.