Support » Plugin: Wordfence Security - Firewall & Malware Scan » Plugin could not be activated because it triggered a fatal error.

  • Resolved happy2bnmarketing

    (@happy2bnmarketing)


    Tried to update other plugins yesterday (don’t think WF was one of them) and got the white screen.

    Deactivated plugins. Pinpointed issue to be WF as it’s the only one I can’t reactivate. I get this message:

    Plugin could not be activated because it triggered a fatal error.

    I don’t see anything about memory issues.

    Hosted on Bluehost. I think it’s php 7.3.11

    Everything else is up to date including WP Version 5.4.2

    I deleted the plugin via WordPress and reinstalled and that didn’t solve the problem. Tried again and purged cache before installing and still didn’t work.

    I have other sites running similarly set up sites running Wordfence no problem, it’s just this one site. Most aren’t on Bluehost though in case that’s a connection. This is probably the only one I manage with that issue.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • I have the same issue. I reactivated all plugins one at a time. The one that fails is Wordfence.

    Same here. I disabled all plugins, turned them on one by one, and then got a fatal error when turning on Wordfence.

    I am on a LiteSpeed server and all my plugins are up to date.

    • This reply was modified 5 months, 2 weeks ago by .

    I’m also seeing this error. Site went offline after maxing out full 2gb ram and 100% cpu for an hour. Disabling WordFence fixed it (renamed folder to .bak). Deleting and reinstalling gives this fatal error problem when I click activate.

    I was having same issue and solved it with:

    1. uninstall wordfence
    2. install wordfence assistant
    3. click the uninstall all tables and data button
    4. click the uninstall firewall button
    5. reinstall wordfence
    6. go through normal setup procedure

    @rtpharry you are brilliant!

    Solved!

    To clarify, delete WF, and reinstall?

    And yes, Brilliant suggestion!

    I deleted WF plugin, and reinstalled. tried to activate (After using the WF assistant), yet same result, fatal error.
    This particular website has had WF for about 4 years without any issues.

    I installed and activated the WF security plugin on a different website, without any problems.

    PhP was in need of a upgrde that was initiated and completed successfully. Any other suggestions?

    I went through the following:
    uninstall wordfence
    install wordfence assistant
    click the uninstall all tables and data button
    click the uninstall firewall button
    reinstall wordfence
    go through normal setup procedure

    Note <ftpuser> is my ftp user and <wordpresssite> is my wordpress site

    But on reinstall of wordfence security got the following error:
    Wordfence generated an error on activation. The output we received during activation was: WordPress database error: [Table ‘<ftpuser>_<wordpresssite>.wpky_wfConfig’ doesn’t exist]SELECT name, val, autoload FROM wpky_wfConfig WHERE name = ‘allowLegacy2FA’WordPress database error: [Table ‘<ftpuser>_<wordpresssite>.wpky_wfConfig’ doesn’…[output truncated]

    I did seem to be able to setup wordfence OK and when I tried reinstalling wordpress it allowed me to without an out of memory fatal error.

    Thank you for this. I had the same issue on a site running litespeed & wordfence after a theme update… No idea what triggered it. Removed all plugins 1 by 1 and sure enough, WordFence was the issue. I wasn’t able to reinstall until following the steps to use the WordFence assistant to remove the tables. Reinstalled and everything appears to be fine… Perhaps this needs to be raised to litespeed & wordfence to track down.

    @rtpharry are you running litespeed as well? Trying to see if there’s a correlation.

    Yeah this has happened with litespeed hosted sites. It’s only happened with 2 out of around 50 site upgrades though.

    I have the same issue on several sites. I followed the above steps with WF assistent (thanks for that solution). That works on some sites but not on all. I noticed that I have this issue after updating the Yoast SEO plugin. On the sites where it did not work to use WF assistent and re-install WF again I rolled back Yoast and that solved the issue. I could activate WF again and do all the settings. Hope it works for others too.

    @rtpharry That worked for me! I used the Wordfence Assistant and cleared everything out. Clearing the firewall took a really long time but I let it finish.

    I’m very concerned now, because I have WordFence on something like 150 websites of mine and if I have to do this for every single one it’s going to be a huge pain. Sounds like WF really messed something up here.

    Note that I was randomly getting fatal errors throughout the site, and they all appeared to be tied to WordFence, even though they weren’t appearing in the error logs for whatever reason.

    Plugin Author WFSupport

    (@wfsupport)

    Putting this here in case anyone else has this problem and comes here looking for a solution and more answers.

    Thanks for reaching out. We’ve been investigating these reports and now think we have a cause and a solution.

    One thing to note, that if you see an error in your logs about running out of memory, it may not be the same issue. It might be a case of needing to allocate more memory to PHP. PHP memory is cumulative. That means the amount set in php.ini is shared between all your plugins, your theme, and WordPress, plus any other non-WordPress apps you have installed in the site folder. We recommend changing it to 256M and upgrading to PHP 7 or above, which introduced better memory handling. If that doesn’t help, please try one of the other solutions mentioned here.

    What we found is that on some sites the emailedIssuesList row in the wfconfig table had became too large from recording hashes of previously emailed scan issues. Reinstalling Wordfence fresh (where the data and database tables are removed) was fixing the issue but this lets us know exactly where the problem was.

    There are 2 ways of fixing this.

    1. If you are comfortable using MySQL queries you can issue this command using PHPMyAdmin in your hosting control panel:
    delete from wp_wfConfig where name = ’emailedIssuesList’;

    2. If you are not comfortable with running queries do this:
    Remove and reset Wordfence, using the Wordfence Assistant plugin to remove all tables and data and then reinstall the plugin.

    We are looking at a solution to prevent it from happening again and hopefully will include it in the next release.

    Thanks always for being patient as we worked diligently to solve this for our customers. Thanks as well for reaching out and providing valuable information to help us solve it. Let us know if this solves it for you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.