Support » Plugin: Wordfence Security - Firewall & Malware Scan » Plugin could not be activated because it triggered a fatal error.

  • Resolved chfriley

    (@chfriley)


    This isn’t a new install, I temporarily deactivated WF to see why I was getting a blank screen (realized it was getting 10-20(???) crawlers per second and had been for 18-20 hours and the server was overwhelmed). WF won’t reactivate now.

    I’ve tried deleting, reinstalling WF a number of times via the WP installer. I’ve downloaded it and tried uploading it manually via the WP installer. I have downloaded it and uploaded it via SFTP, always the same error:
    “Plugin could not be activated because it triggered a fatal error.”

    Turning on these, results in no errors on the display, in the apache error log, or the php error log.
    //define(‘WP_DEBUG’, true);
    //define(‘WP_DEBUG_LOG’, true);
    //define(‘WP_DEBUG_DISPLAY’, true);
    //@ini_set(‘display_errors’, E_ALL);

    I have checked to ensure that there are no leftover directories (e.g. wflogs) after deleting.

    There ARE about 22 tables in the DB – wp_wfBlockedIPLog, wp_wfBlocks7, wp_wfConfig etc, all with the wp_wf prefix – that seem to be related to word fence, but I haven’t deleted them since I didn’t want to mess something else up.

    It is running reasonably current versions:
    WP 5.4.1
    server_architecture: Linux 3.10.0-957.12.2.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.17 64bit
    server_version: 10.2.25-MariaDB
    client_version: mysqlnd 5.0.12-dev
    max_input_variables: 16384
    time_limit: 600
    memory_limit: 2048M

    Thanks for the help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same issue on our site. I had to deactivate Wordfence as it was throwing out of memory errors suddenly, now it won’t reacitvate at all.

    Memory: 92.5 of 256 MB (36%) | WP LIMIT: 40 MB | PHP 7.2.31

    billyf

    (@excited4coupons)

    Same here as well. Wordfense was using so much memory on my site. After disabling all plugins on by one it was wordfense slowing it down. I was on php7.2 So when I changed to php7.4 it wasnt even working. So I disabled wordfense and my website was able to work again. So i removed wordfense and tried to put it back but received the Plugin could not be activated because it triggered a fatal error.

    Things were working fine before not sure what happened. So since I couldnt get wordfense working I had to add iThemes Security instead because a website needs some security.

    I was concerned it was something site specific, and over the course of a week I spent 10-12 hours looking at various things too, checking the DB, seeing if it was something that didn’t get removed properly when I had to deactivate it etc. I am glad it isn’t only my site experiencing this.

    I tried some others, but hadn’t tried iThemes Security. I am going to do so now.

    Hey @chfriley,

    Thanks for sharing the system information. I’ll share this with the developers.

    If anyone else that’s experiencing this can share system information it may be helpful as well.

    Thanks,

    Gerroald

    I’m experiencing the same issue.

    WP Version: 5.4.1
    WP Memory Limit: 256 MB
    WP Debug Mode: No
    WP Cron: Yes
    Server Info: Apache
    PHP Version: 7.2.29
    PHP Post Max Size: 128 MB
    PHP Time Limit: 300
    PHP Max Input Vars: 3000
    cURL Version: 7.69.1, OpenSSL/1.1.1f
    Max Upload Size: 128 MB

    Had to use WF Assistant to delete all WF tables, reinstalled WF and it’s working now. Have sent diagnostics report via the plugin. Have a system info file that I downloaded before deleting WF and reinstalling if it helps at all – could email it to you.

    @wfgerald this seems like the issue I opened a ticket about last week. Memory issues, crashing the database, and now cannot reactivate it.

    I’ve sent over my system status on the other thread as well.

    I’m sure your team will be all over this ASAP.

    Thanks in advance.

    Paul

    • This reply was modified 5 months, 2 weeks ago by touchestudio.

    I upgraded PHP from 7.2 to 7.3 and Wordfence crashed the site. I disabled the plugin and everything got back to normal. However, I can’t activate the plugin again because it causes a fatal error.

    This happened to all my sites.

    I love Wordfence, so I hope this issue is solved ASAP.

    Thanks!

    @garyjh28 is right

    I was having same issue and solved it with:

    1. uninstall wordfence
    2. install wordfence assistant
    3. click the uninstall all tables and data button
    4. click the uninstall firewall button
    5. reinstall wordfence
    6. go through normal setup procedure

    @wfgerald your team as probably solved this but it’s happened to another client now and I’ve taken a backup before doing the fix. If it will help you diagnose the root issue I can share it with you. If so, where should I send the download link to?

    I too installed WordFence Assistant and did the clear all tables which resolved it and let me re-activate it successfully.

    I would suggest an improved error message indicating that there are WF tables in the DB for example. I had mentioned the extra tables left in the DB in the first message, but didn’t want to delete them manually.

    🙂

    p.s. I think the issue occurred when the site was getting really hit by spiders and WF was using a lot of memory etc. Deactivating it during that time resulted in it not deactivating completely (e.g. removing the last of the tables) which didn’t let it reinstall. Just a guess based on what happened with the sites. Some get a fair amount of traffic at various points.

    Plugin Author WFSupport

    (@wfsupport)

    Adding this in case someone has the same issue and comes here looking for answers.

    Thanks for reaching out. We’ve been investigating these reports and now think we have a cause and a solution.

    One thing to note, that if you see an error in your logs about running out of memory, it may not be the same issue. It might be a case of needing to allocate more memory to PHP. PHP memory is cumulative. That means the amount set in php.ini is shared between all your plugins, your theme, and WordPress, plus any other non-WordPress apps you have installed in the site folder. We recommend changing it to 256M and upgrading to PHP 7 or above, which introduced better memory handling. If that doesn’t help, please try one of the other solutions mentioned here.

    What we found is that on some sites the emailedIssuesList row in the wfconfig table had became too large from recording hashes of previously emailed scan issues. Reinstalling Wordfence fresh (where the data and database tables are removed) was fixing the issue but this lets us know exactly where the problem was.

    There are 2 ways of fixing this.

    1. If you are comfortable using MySQL queries you can issue this command using PHPMyAdmin in your hosting control panel:
    delete from wp_wfConfig where name = ’emailedIssuesList’;

    2. If you are not comfortable with running queries do this:
    Remove and reset Wordfence, using the Wordfence Assistant plugin to remove all tables and data and then reinstall the plugin.

    We are looking at a solution to prevent it from happening again and hopefully will include it in the next release.

    Thanks always for being patient as we worked diligently to solve this for our customers. Thanks as well for reaching out and providing valuable information to help us solve it. Let us know if this solves it for you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.