Support » Plugins and Hacks » [Resolved] Plugin could not be activated because it triggered a fatal error.

[Resolved] Plugin could not be activated because it triggered a fatal error.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Bas Schuiling


    The same as here?

    Let me know if downloading the latest version from here http://plugins.svn.wordpress.org/faf/trunk/feedwordpress_advanced_filters.php fixes the problem.

    Fixed with latest update from the author, along with updating my web server to PHP 5.3 or greater. The plugin will NOT work with PHP 5.2.17 (what I had before).

    Plugin Author Bas Schuiling


    I have include the requirement of PHP 5.3 in the description on WordPress now so it is more clear 5.3 is needed.

    I have PHP 5.3.3 installed (“5.3.3-7+squeeze15”) and still getting this error while trying to activate the plugin.

    Fatal error: Call to a member function getFilename() on a non-object in /var/www/wp-content/plugins/faf/feedwordpress_advanced_filters.php on line 89

    When I tried with the svn linked one above, I get the same error.

    The line that triggers the error is this:

    $extension = pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION);

    I added a print_r($fileInfo); at the point where the error happens and got the following:

    DirectoryIterator Object ( [pathName:SplFileInfo:private] => /var/www/wp-content/plugins/faf//filters/categories_keyword.php [fileName:SplFileInfo:private] => categories_keyword.php [glob:DirectoryIterator:private] => [subPathName:RecursiveDirectoryIterator:private] => )

    So it appears that the object is being handled wrong, not an issue of PHP support.

    I tried downgrading to the 5.5 version. Now i get this error:

    Fatal error: Call to undefined method DirectoryIterator::getExtension() in /var/www/wp-content/plugins/faf/feedwordpress_advanced_filters.php on line 81

    I’m running without a problem in the PHP 5.4.13

    Plugin Author Bas Schuiling


    Hum I didn’t get any emails notificating me of new posts here, sorry.

    The problem was fixed in version 0.5.8 . If you have this version try to redownload.

    Problem was that the function I’m using is new since version 5.3.6 and I didn’t notice that before. There is a check now if you look in the SVN.

    Hope this helps, let me know if not.

    Thanks for the tips (and the amazing plugin).
    I was getting the same error with 0.5.8.
    I managed to get the plugin to install by commenting out the offending sections:

    //if (version_compare(PHP_VERSION,"5.3.6","<"))
    //      $extension = pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION); // compat for 5.3 - 5.3.5
    //      $extension = $fileInfo->getExtension();
    //if ($extension == "php")

    The filters sections are appearing fine on FWP.
    We’ll see if the filters work now.

    Plugin Author Bas Schuiling


    Thanks for that, I will look into it It just sucks – its hard to test against the other 26 php .3 (in php 5.4 everything is just splendid ) versions with a normal setup so please keep testing and reporting 🙂

    Plugin Author Bas Schuiling


    You can try and get the latest file from the development version SVN. The problem should have been fixed. The lines you commented out are loading in the filters so obviously they should not work unless witchery is involved.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.