Support » Plugin: Page View Count » Plugin could not be activated because it triggered a fatal error

  • Resolved AndrewAshling

    (@andrewashling)


    After latest update my site was offline.

    My ISP provided the following:
    “[error] [client 141.135.174.223] PHP Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/XXX/public_html/wp-content/plugins/page-views-count/admin/admin-ui.php on line 37”

    I had to manually removed the plugin and the site went back online. When I tried to reinstall from a fresh download WP gave me the same message:

    “Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/XXX/public_html/wp-content/plugins/page-views-count/admin/admin-ui.php on line 37”

    • This topic was modified 1 year, 5 months ago by  t-p.
Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m experiencing the same thing: site went offline after latest update 2.0.3 with same error:

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in “/home/content/03/xxx/html/wp-content/plugins/page-views-count/admin/admin-ui.php on line 37”

    I also had to rename the plug-in to pull it offline.
    Please fix as this is a very useful plug-in for me.

    I’m running the latest version of WordPress and no changes have been made to anything on my site since at least a day before the auto update of the plug-in.

    Also, which sub-file contains all my page counts and settings and needs to be restored once this is working?

    Yep same here after updating to 2.0.3 >> wp-content/plugins/page-views-count/admin/admin-ui.php on line 37

    Had to roll back to 2.0.2

    @easykorean “Also, which sub-file contains all my page counts and settings and needs to be restored once this is working?” That info is held in the database, so for now install Version 2.0.2 and you counts & settings will all be back.

    Your PHP Version < 5.6.0?

    Well, after installing the update and my blog going down I ended up here. Is there going to be a fix for this?

    Plugin Author Steve Truman

    (@a3rev)

    @andrewashling, @easykorean, @mmicrosysm, @ginawhipp

    Have checked and see the error that you are having is an incompatibility with PHP version 5.5.

    PHP stopped support for 5.5 in July 2016 and strongly recommend that it is not used due to security vulnerabilities – see here
    http://php.net/eol.php

    WordPress Requirements state that to run WordPress system config should be
    PHP version 7.2 or greater
    MySQL version 5.6 or greater OR MariaDB version 10.0 or greater
    HTTPS support

    You can read more about that here https://wordpress.org/about/requirements/

    There is a sample email text that you can use on that page to send to your host to upgrade your system. As soon as you upgrade to PHP 5.6 or higher you will not have the issue.

    Regards
    Steve

    Thanks for the quick response, Steve. I restored 2.0.2 fro ma WordPress VaultPress backup easily (didn’t realize how easy that was). And the data/settings for this plug-in remained as you said-even after deleting the Plugin folder. 🙂

    I did find an option in my host admin control panel to upgrade from PHP 5.3 to 5.6. I will try that and hope that the upgrade doesn’t affect other plug-ins. Thanks for your support.

    • This reply was modified 1 year, 5 months ago by  easykorean. Reason: Update:

    I get a fatal error when trying to activate this plugin:
    Parse error: syntax error, unexpected ‘[‘ in /hermes/walnaweb04a/b2638/moo.davidpowercomau/portal/wp-content/plugins/lifterlms/includes/abstracts/llms.abstract.database.store.php on line 108

    Plugin Author Steve Truman

    (@a3rev)

    @sharonnash

    Please read my reply above.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error’ is closed to new replies.