Support » Plugin: Email Before Download » Plugin could not be activated because it triggered a fatal error

  • Resolved D L

    (@petacciato)


    WordPress did not notify me of the long-lasting update of this plugin
    Today I updated the plugin from version 3.0.4 to 5.0.6 from ManageWP:

    Parse error: syntax error, unexpected ‘[‘ in …../home/wp-content/plugins/email-before-download/includes/class-email-before-download.php on line 93

    I tried to restore version 3.04 from FTP but the plugin now no longer sends the email

    • This topic was modified 3 years, 9 months ago by D L.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The old version produced a fatal error.

    I just tried to upload the new version and I get the same problem

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in …/wp-content/plugins/email-before-download/includes/class-email-before-download.php on line 93

    Thread Starter D L

    (@petacciato)

    My current configuration is:

    WordPress Core v.4.9.2
    Download Monitor v. 4.0.1
    Contact Form 7 v. 4.9.2
    Email Before Download v. 5.0.6

    • This reply was modified 3 years, 9 months ago by D L.

    Hi, same problem here. Same versions of wordpress and plugins as the previous poster. PHP version is 5.3.3.

    It’s looking like php 5.3.3 doesn’t support something in the syntax. Running the following generates the error shown with php 5.3.3 but not with later versions of php:

    php -l class-email-before-download.php

    PHP Parse error: syntax error, unexpected ‘[‘ in class-email-before-download.php on line 93

    Thread Starter D L

    (@petacciato)

    I have updated the version 5.3.29 of the PHP server to 5.6.32 and I have solved the problem. Now the plugin is activated and I’m setting all the options from the beginning…

    • This reply was modified 3 years, 9 months ago by D L.

    I confirm that upgrading PHP to a more recent version has allowed me to re-activate the plugin. Thanks.

    Thread Starter D L

    (@petacciato)

    Perfect!

    I had the same issue, a PHP Parse error: in class-email-before-download.php

    A php upgrade to php 5.5 sorted this issue

    Thread Starter D L

    (@petacciato)

    Perfect the problem has been solved

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error’ is closed to new replies.