Support » Plugin: ReportAttacks » Plugin could not be activated because it triggered a fatal error.

  • Resolved jshare

    (@jshare)


    Latest WordPress, Multisite-enabled, PHP7.

    When I tried to activate, I get the above error and this message:

    Parse error: syntax error, unexpected end of file in /var/www/xxxxxxx/html/wp-content/plugins/reportattacks/functions/functions.php on line 764

    This happens whether I try to activate on one blog (the primary one) or network activate.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author sminozzi

    (@sminozzi)

    Hi Jshare,
    Thanks by let me know about this issue.
    This is the first time i hear about this issue.
    I removed all spaces at end of line 764 (the last line of file) and created the version 2.0
    Please, try install again and let me know if works now.
    Cheers,
    Bill

    Installed version 2.0 but I still get the fatal error, same location, this time on line 511

    Plugin Author sminozzi

    (@sminozzi)

    Thanks for the update. I removed all blank lines, then this file have now only 511 lines. I empty all to end of file.
    Please, let me do some research to find some solution because this is very unusual.
    If you have time, please, try to deactivate all anothers plugins and try to activate again. Maybe have some conflit…
    I will keep in touch.

    Plugin Author sminozzi

    (@sminozzi)

    I just double checked the file (functions.php), not erros found.
    What your’s PHP Version?
    Is your hosting linux or php-windows?
    Did you get this same message from another plugin or theme?

    PHP 7.0.11-1+deb.sury.org~precise+1, latest WordPress, Multisite-enabled, hosted on Ubuntu 12.04.

    Fortunately, I haven’t seen this message with other plugins recently.

    Plugin Author sminozzi

    (@sminozzi)

    I didn’t try it in multisite. Do you have in this server any site not multisite?
    If you have time, please, try to deactivate all anothers plugins and try to activate Report Attacks again. Maybe have some conflit with some plugin or theme at your server.

    I would need to setup a test server for that. I don’t have time for that right now, but maybe the next time I set one up.

    Plugin Author sminozzi

    (@sminozzi)

    I have a dedicated linux server in USA with around 30 wordpress sites. (no multisite).
    The plugin works fine.
    This plugin was installed also in dozens of anothers servers, no problems found.
    When you have time to run more tests, like disable anothers plugins, please, let me know.
    If you need this plugin installed, i can install it for you for free, but i will need your FTP user / password and cpanel user password to run tests. In this case, i’m sure i will find what happens.
    Just let me know.
    If you want only improve the protection but not report attacks, we have the free antihacker plugin at wordpress directory. You can try to use it.
    Here is the url:
    https://wordpress.org/plugins/antihacker/
    Anyway, when you have time, please, send me some feedback about.
    Cheers,
    Bill

    Plugin Author sminozzi

    (@sminozzi)

    Hi Jshare,
    I review all code and i find today a small issue. Sometimes in some php server open php only with <? can create problems. Then i replace it with <?php
    When you have time free, please, try the version 2.01 (uploaded today) and let me know.
    Cheers,
    Bill

    2.01 works! Good job! Installed without a problem.

    Plugin Author sminozzi

    (@sminozzi)

    Great!
    Thank You for your update.
    i’m happy.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.