Support » Plugin: Subscribe2 » Plugin could not be activated because it triggered a fatal error.

  • Resolved helenjbeal


    On trying to activate a new installation of plugin subscribe2 I get the following error message:

    Warning: require_once() [function.require-once]: Unable to access /var/www/vhosts/ in /var/www/vhosts/ on line 57

    I have contacted my service provider who have tried changing my permissions and manually installing the plugin but without success – does anyone have any suggestions on what the problem is and how we can fix it please?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The hosting service provider (Domain Express) is now saying the plugin is corrupt – is this really the case?


    Corrupt? I’m not sure about that but it certainly is incompletely installed. Did you install from the WordPress menu system or manually?

    Erase it and try again, if that fails erase and try the other method.

    Hey thanks @mattyrob – we’ve tried erasing and installing using both WP and manual methods with no success… I was dubious about the suggestion that the plugin was corrupt which I think came across in my comment – if you have any other ideas about what might be the problem that would be super helpful!


    Download the latest version from here and unarchive it on your desktop computer. Then use FTP software like FileZilla to upload the entire Subscribe2 folder and all of it’s contained files and folders to wp-content/plugins.

    That’s the totally manual way and will hopefully work.

    Hi @mattyrob

    I have now successfully installed and activated the Subscribe2 plugin – however, it appears there was a conflict with this plugin: which “Adds a Follow button at the right bottom corner of your WP.ORG site.”

    I resolved the issue by deleting this plugin and reinstalling the Subscribe2 plugin which then activated successfully.

    HOWEVER – when I then reinstalled this plugin I got:
    “Plugin could not be activated because it triggered a fatal error.
    Fatal error: Cannot redeclare class s2class in /var/www/vhosts/ on line 55″

    I will write to the developer of this plugin also to let them know of the problem – however, any suggestions you have will be gratefully received.

    Also – I am not sure how to use the Subscribe2 plugin without a widget or button plugin to actually place the function on my pages. I also have tried the Subscribe2 widget that’s available but that did not appear to link to anything meaningful…

    Thanks for all your help – Helen

    I also wanted to mention that I just tested this on another site – and am getting the same errors…


    It would seem that the Follow plugin duplicates a significant proportion of the code in Subscribe2 and makes minor changes to the front side display.

    As I’m sure you can see ‘s2class’ is a reasonable name to give the class of code in Subscribe2. The entire class really should be renamed if another plugin is copying large segments of the Subscribe2 to avoid just this sort of conflict.

    The two plugins cannot currently be used on the same site and this would need fixing in the Follow plugin.

    Okay does that mean that I’ve misunderstood that the Follow plugin doesn’t operate without Subscribe2? I assuming it relied on it.

    Is S2 something different to Subscribe2?

    Thank you so much for your time – I wouldn’t be sure about anything I know – I am not a coder – I have worked in IT all my working life but I sell this stuff… I don’t speak all the language so I get a little lost at moments like these… I’ve not had a response from the Follow people yet but will update this thread as / when I do. Thankyou @mattyrob!


    Follow does not need Subscribe2 directly, as I said above it has essentially copied a large portion of the Subscribe2 code so while it has duplicated much of my code it should work independently of Subscribe2 as a separate plugin.

    That said, Follow is not my plugin and is hasn’t been updated for 9 months, it also seems to be using an amended version of Subscribe2 probably around version 6.5 released about 18 months ago so I cannot really comment further on it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.