Support » Plugin: AdVert » Plugin could not be activated because it triggered a fatal error.

  • Resolved BLUMedic

    (@blumedic)


    Hello,

    I wish to try out this plugin but I get the following error when trying to activate it.

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /home/figtreeads/public_html/working/wp-content/plugins/advert/includes/class-advert.php on line 69

    Trying to delete the plugin gives the same error.

    Any advice?

    https://wordpress.org/plugins/advert/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author norths

    (@norths)

    What are your:

    • WordPress version
    • AdVert version
    • PHP version

    If your using a PHP version below 5.4 you might receive this syntax error.

    Thread Starter BLUMedic

    (@blumedic)

    Ah, using latest version of WordPress and AdVert, but PHP 5.3.29. Thanks for that, I have it working now.

    Might be worth adding that you need PHP 5.4+ for it to work. Thank you.

    How do I know which php I have and how to update it?

    Changing the PHP Version:
    Log into cPanel.
    Click the PHP Configuration button in the Software/Services section. …
    Select the version of PHP you want to use from the dropdown.
    Click the Update button to save your php configuration.
    Check your changes by viewing your settings in a phpinfo page.

    Also
    https://codex.wordpress.org/Switching_to_PHP5

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.