Support » Plugin: Cookillian » [Plugin: Cookillian] My Alerts widget doesn't display, & has style="display: none;&quo

  • PaulCutcliffe



    I’ve recently implemented Cookillian on one of my own websites, & am very pleased with the results. So I’ve now implemented it on a client’s website, only to find that the notification doesn’t display.

    On further investigation, I can see this on the site on which it works:

    <div class=”cookillian-alert” style=””>

    … whereas on the site on which it doesn’t display I can see this:

    <div class=”cookillian-alert” style=”display:none;”>

    I am opening both sites in one of Google’s ‘incognito’ windows, so neither are logged in or have cookies stating that it should or shouldn’t be displayed, so I’ve no idea why the client’s website has added style=”display: none;” to its tag. The Cookillian Settings are set exactly the same on both sites.

    Does anyone have any idea why this could be happening?

Viewing 4 replies - 1 through 4 (of 4 total)
  • PaulCutcliffe


    Strangely, I’ve found that if I click on a Reset Cookie Preferences link (?cookillian_resp=2), then the notification is displayed, but when you click to another page or two, it becomes hidden again.


    Plugin Author myatu


    By default, the style includes “display:none” – it gets removed by an AJAX call once it has been determined the alert should be shown. This has been done to avoid caching issues (ie., WP Super Cache).

    So it seem that at your client’s site, the AJAX is returning data to not show the alert. If you click the Debug link at the bottom of the Settings page (WP Admin -> Settings -> Cookies), you will find what IP has been detected and the associated country. Double check that this is correct on your client’s site, and that it matches a country for which the alert should be shown – it is possible a proxy is interfering with this, for example. Also, the alert must show for a logged-in user if you have enabled the Debug Mode.

    As for the notification disappearing on a subsequent page view, this is when the Implied Consent is enabled.



    Thanks for the quick response, however for some reason, the two sites appear to work differently with regard to implied consent.

    I was expecting the Implied Consent setting to allow cookies as if the user had given explicit consent, but also to continue to display the message until they actually clicked on the Yes or No option regarding consent. This is how my own site seems to work, at least as far as displaying the message is concerned (I haven’t actually checked its cookie usage).

    Can you confirm that with Implied Consent enabled, the user should only see the message regarding cookies once? Also, is that once per visit, or once ever?

    If it helps, I’d be happy to provide you with the two sites’ URLs so you can see how they are each working?

    Thanks again for your assistance,

    Paul Cutcliffe
    Eastbourne Websites

    Plugin Author myatu


    With Implied Consent, the alert will be shown once ever, provided the visitor continues to use any other part of the same website.

    So to explain: if the visitor accesses and is shown the alert, then proceeds to, the alert will not be shown again for this visitor (using a cookie).

    Keep in mind, that only when the visior proceeds to another part of the website this happens (the “required action” part of implied consent). So if the visitor lands at, but goes no further, then in a next browser session (close/re-open) visits it again, the alert will also be shown again.

    As for the differences between the two sites, I am keen to find out what may be causing this so it can be corrected. If you’d rather not publicise the URLs, feel free to contact me directly at (referencing this forum entry).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Cookillian] My Alerts widget doesn't display, & has style="display: none;&quo’ is closed to new replies.