Support » Plugin: Cookillian » [Plugin: Cookillian] Message / pop up not showing

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author myatu

    (@myatu)

    Hi!

    The message will not show up for users that have already logged in to WordPress (unless Debug Mode is enabled under the Advanced Settings).

    Also, at the bottom of the Cookies/Settings page, you will find a Debug link. Clicking it will show some extra information, including your current IP and location (ie., “United Kingdom”). This verifies that the correct GeoIP information was obtained from CloudFlare.

    Hi,

    Thanks for fast reply. I’ve also tried to test message with using different browser (IE), deleted cookies in both browsers (IE and FireFox), tried to log out and also using debug mode, but message didn’t show up. Any idea what could be wrong?

    Kind regards

    Same problem here. In the page source I see
    <div class="cookillian-alert" style="display:none;">

    Why?

    Plugin Author myatu

    (@myatu)

    … and also using debug mode, but message didn’t show up.

    This means that something is interfering with the AJAX requests, and never receives the “signal” to display the alert. If you have an URL of where this occurs, I’d be happy to take a look and try find the cause.

    Same problem here. In the page source I see … Why?

    The alert is always written as the page output, but initially hidden. This is to accommodate caching plugins such as WP Super Cache, as well as users that do not have Javascript enabled (an additional stylesheet is loaded within a <noscript> tag that overrides the "display:none" bit and hides non-functional items).

    For those that do have Javascript enabled, an AJAX call will determine if the alert should be displayed, and move it to the top of the content and remove the "display:none".

    I’ve tried plugin with other host (where I will use it) and I get error message:

    Fatal error: Call to undefined function Myatu\WordPress\Cookillian\mb_convert_case() in /home/optimiza/public_html/wp-content/plugins/cookillian/app/Myatu/WordPress/Cookillian/Main.php on line 111

    What could be wrong?

    Myatu, can you please have a look at http://www.nostromo.nl? I’ve added and activated the plugin there, but the warning is never displayed (even with all history/cookies deleted, other browsers etc.)

    I have deactivated all plugins and activated them again, now it seems to work.

    And now it doesn’t work anymore… I’m out of ideas. Help is appreciated…

    Some more info. Enabled Debug. In the script console (chrome) I see this error:
    Uncaught TypeError: Object #<Object> has no method 'postInit'

    In firefox console is see this error:
    cookillian.postInit is not a function

    Plugin Author myatu

    (@myatu)

    Hi, sorry for the delayed reply. A few others have reported the same problem, and I will try to get this fixed ASAP. Sorry about that!

    Getting a similar error: “cookilian.displayAlert is not a function” – see http://www.whatwasithinking.co.uk/

    Checked all other dependencies, jQuery etc is all running fine, I expect this is the same bug as outlined above?

    Plugin Author myatu

    (@myatu)

    Hi!

    It is indeed the same bug, and I hope to be able to push out the fix today, pending a work-around for a browser bug (in FF 13).

    Behind the scenes, what’s happening is that the plugin responds to multiple wp_print_script actions, when it’s only supposed to do so once, overwriting previous values in the Javascript (some other plugins and themes may trigger this action multiple times).

    Plugin Author myatu

    (@myatu)

    @ninostar78:

    Fatal error: Call to undefined function Myatu\WordPress\Cookillian\mb_convert_case()

    This is because PHP was not compiled with Multibyte support. However, I’ve created a work-around for this in the v1.1.13 release. Hopefully you can use it now 🙂

    @marcel Bootsman, @thorandor:

    I’ve addressed the issue where Cookillian responded to multiple wp_print_script actions, which should fix the bug you were experiencing. Let me know if this resolves it for you.

    @myatu,

    The problem seems to solved. Thanks a lot!

    @myatu: Thanks for quick fix and the message is displayed now. I have one more question although. Cookies seem to load in browser at once and it doesn’t matter if I select yes or no. As I know EU directive doesn’t allow cookies to load before you get consent of the visitor, so how can I disable loading of cookies and how is it possible not to load them, if visitor clicks on no.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: Cookillian] Message / pop up not showing’ is closed to new replies.