WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Cookies for Comments] Stylesheet present, Cookie Not Being Dropped

[Plugin: Cookies for Comments] Stylesheet present, Cookie Not Being Dropped

  • Hi Donncha –

    I used this plugin successfully for a while, and it really helped me wheedle out the wheat from the chaff.

    However, a few months ago, it appears to have stopped working. I’ve browsed the other discussions on the topic, and here’s where I’m at:

    1) The 32-digit stylesheet is appearing in the source code. When I load the stylesheet manually into the browser, it shows blank.

    2) However, when I check my cookies, I am not seeing a corresponding 32-digit cookie having been set.

    In the source code I see this:
    <link rel="stylesheet" href="http://www.zombiephiles.com/3ad9ac3bc26159d7498579acd530eee1.css?t=1719086234" type="text/css" media="screen" />

    However, the only cookies I see are comment_author_email and comment_author (which shows as [Blocked by CFC] after I’ve tried to test comments).

    I’ve tried deactivating the plugin and deleting it, then re-uploading the plugin and reactivating; however, this doesn’t seem to be doing the trick.

    I’d love to get CFC working again, since I get 100+ comments slipping past Akismet monthly that CFC stops; however, it’s also stopping ALL other comments (except trackbacks) since the cookie isn’t being set.

    On the off-chance that there’s a conflict with another plugin that I’m running, I’m including the current plugin list. Not all plugins are currently up-to-date.

    Add to Any: Share/Bookmark/Email Button – .9.9.3
    Akismet – 2.2.6
    All in One SEO Pack – 1.5.7
    Cookies for Comments – 0.5.1
    Executable PHP widget – 1.2
    Google Analytics – 2.5
    Google XML Sitemaps – 3.1.4
    Kimili Flash Embed – 2.0.1
    Popularity Contest – 2.0b2
    SEO Title Tag – 2.3.3
    Twitter Tools – 1.6
    User Photo – 0.9.4
    Viper’s Video Quicktags – 6.1.20
    WP-Polls – 2.40
    WP-Polls Widget – 2.40
    WP Cache Inspect – 0.8.2
    WPG2 – 3.0.7
    WP Super Cache – 0.9.4.3

    Offhand, I don’t know which of those would be causing problems with CFC, except possibly WP Super Cache, but that’s a commonly used plugin so I’m sure we would already have heard of incompatibilities with yours.

    Any thoughts on how I can find some more information about the problem? Are there DB tables that I can drop to “reset” the plugin, or is that accomplished by deactivating it? I’m not entirely a novice, but I’m not entirely an expert either; however, I’m good with instructions.

    Eagerly looking forward to hearing back from you about this issue. Thanks, as always!

Viewing 1 replies (of 1 total)
  • I loaded your stylesheet above and unfortunately it didn’t set a cookie on my machine. You should edit the plugin and find the setcookie() command. Add a mail() or error_log() before that command just to verify that it’s being called. You should also check your error log to see if anything’s there.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Cookies for Comments] Stylesheet present, Cookie Not Being Dropped’ is closed to new replies.
Skip to toolbar