WordPress.org

Support

Support » Plugins and Hacks » Contextual Related Posts » [Plugin: Contextual Related Posts] Lost everything after 1.8.2 upgrade

[Plugin: Contextual Related Posts] Lost everything after 1.8.2 upgrade

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Ajay

    @ajay

    Hi,

    I am checking out http://www.vegasnews.com/75641/american-burger-works-to-celebrate-independence-day-with-all-american-combo.html and seems like you have a “Related Content” section. Is this via my plugin?

    Yes, that is your plug in working on my main site. I had to delete the 1.8.2 plugin, restore the database and reinstall 1.8 to get it working again. I was wondering if there was something about 1.8.2 that required WP 3.4 because I haven’t upgraded VegasNews.com yet.

    Plugin Author Ajay

    @ajay

    I don’t have any 3.4 specific functions. However, 3.4 has seen a lot of code changes and it could be possible something didn’t match up.

    Were you getting any specific error?

    No, I didn’t see any errors. But I got to think that maybe the thumbnails weren’t showing up because the permissions were wrong on that directory. It may have been as simple as that.

    One related question, will the plugin still recognize css settings that are in the main style.css or do they need to be moved into the plugin’s settings page?

    Okay, I tried upgrading to 1.8.3 with the same problem (I have a screen shot if you want it). This time I’m going to delete CRP completely and install it from scratch. I’ll let you know.

    Once again I tried completely deleting CRP and tried to install the latest 1.8.3 from scratch. Same issue. Permissions are correct on Timthumb but that cache is empty, even after re-indexing. So I put 1.8 back in and it’s working again. It takes a while for me to test this because I have 30,000+ images in the site.

    As a side note, can we get an option to add “no follow” to these links? Google used to say I had 30,000 images and not they say I have 70,000 which probably won’t make them happy.

    But on a positive note, this plugin did increase my page views and decrease my bounce rate. I think it’s also the only one that can handle a database this big.

    Plugin Author Ajay

    @ajay

    Is there an issue only with thumbnails?

    There are two things worth checking.
    1. Disable the timthumb option. This only kicks in if your posts don’t have the inbuilt WordPress post thumbnail.
    2. Use the inbuilt WordPress post thumbnails feature.

    Unfortunately, the second will be a bit more painful if you haven’t already activated it via your theme and won’t reflect on old posts. This is where timthumb jumps in.

    Am glad to know that the plugin handles your database well. It is really positive feedback.

    With W3 Cache or WP Super Cache the performance should be a lot better.

    Can you send me the screenshot?

    Plugin Author Ajay

    @ajay

    Regarding your CSS question, you can use a CSS stylesheet (which should be ideal), but many users don’t know how to edit their themes or just prefer not to and that’s where the CSS styles tab comes into play.

    It’s also the basis for a new feature I plan to add in v1.9

    Since I got everything working again with 1.8 and Timthumb I don’t think I’m going to do anymore experimenting until after I backup my site and try the upgrade to WP 3.4.

    But please consider the “no follow” feature. On a big site like mine it’s a serious issue. Thanks.

    Plugin Author Ajay

    @ajay

    I will add that option in the next version

    Ajay, I finally figured out why I was having problems with the upgrade. I think this will be useful info for you. I decided to upgrade VegasNews.com to WP 3.4 before trying another upgrade to CRP 1.83 (from 1.8 which was still working). When I tried upgrading, once again the thumbnails were gone. It turned our there were two minor issues that together really fooled me.

    1. During the upgrade, the Timthumb directory gets rewritten and the default permissions prevent Timthumb and its cache from working. Changing to 777 allowed thumbnails to be made again. But some were still missing here and there.

    2. And here’s why. You do a great job of saving the CRP settings during the upgrade, including the fact that you retain the link to a custom “no image” png. But during the upgrade, the CRP directory is overwritten so the custom png file is deleted. With the custom CSS settings that I have you can’t really tell when a thumbnail is missing or if the custom png is missing. As soon as I replaced the custom png, everything displayed properly again. I guess I could put the custom png somewhere else but I just now thought of that. 🙁

    The bottom line is that it’s not a CRP problem but if your upgrade routine could deal with these issues it might reduce some confusion.

    Once again, CRP is one of the best plugins of all time! Thanks again for all your help.

    Plugin Author Ajay

    @ajay

    Thanks for the thorough testing. Unfortunately, there is little I can do with regards to the upgrading part (unless I am missing some feature of WordPress)

    The way WordPress works is that it deletes the plugin directory and replaces it with the fresh download. I think the biggest reason for this is to ensure that old files do not remain back when a plugin is updated and you always have the freshest copy.

    That being said, I strongly suggest uploading your custom images in the /uploads/ folder possibly using the media manager within WordPress (Media > Add New)

    Am glad to know you love the plugin so much. I’ve got some good features to add in the pipeline on the road to 2.0

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Contextual Related Posts] Lost everything after 1.8.2 upgrade’ is closed to new replies.
Skip to toolbar