Support » Plugin: Contact Form 7 » [Plugin: Contact Form 7] Warning in Dashboard (WP ver. 3.4)

  • After plugin upgrade, WP ver. 3.4 display a warning message in Dashboard:

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /home/mhd-01/www.jqueryitalia.org/htdocs/wp-content/plugins/contact-form-7/includes/capabilities.php on line 14

    To resolve this problem change:

    if ( array_key_exists( $cap, $meta_caps ) )
    			$caps[] = $meta_caps[$cap];

    with:

    if (!empty($cap)) {
    		if ( array_key_exists( $cap, $meta_caps ) )
    			$caps[] = $meta_caps[$cap];
    	}

    Regards.
    Davide.

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Contact Form 7] Warning in Dashboard (WP ver. 3.4)’ is closed to new replies.