WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » [Resolved] [Plugin: Contact Form 7] Still doesn't work

[Resolved] [Plugin: Contact Form 7] Still doesn't work

Viewing 15 replies - 1 through 15 (of 64 total)
  • I had a problem with this as well.

    To chase down the problem, I installed the “Email Log” plugin to verify that WordPress was sending the emails. I then installed “Configure SMTP” to override the outgoing server settings. I tried sending through GMAIL but that didn’t work. I changed my email address under WordPress>Settings>General to wordpress@mydomain.com (I actually had to create that email address on my mail server). Then I set the contact form to send to an internal email address – webmaster@mydomain.com (which I then forwarded to the external address that I actually wanted to send to info@otherdomain.com).

    Not the cleanest solution but I didn’t have time to track down the problem and this works for now. I also recommend “Contact Form to DB Extension” so you can store all submissions to a database and verify it every couple of days.

    I’m sure I could solve the problem the right way if I knew anything about email servers and mx records, but I don’t.

    i’m having this same problem.
    i’ve tried two domains one of them being gmail. i don’t really want to do what’s outlined above, but i will if necessary.
    it was working fine a few days ago, now nothing.

    are there any other solutions to this problem?

    i installed “email log” and tested my contact form – email log saw the email. i did not receive it.

    i installed “configure smtp” and was able to use the “use gmail” checkbox successfully.

    now, i have no idea why this would happen all of a sudden, but whatever…it’s working again.

    I gave up on it.

    did you try what dalewarner describes?
    that worked for me and i’m receiving my contact forms again

    Give me a minute

    An error was encountered while trying to send the test e-mail.

    SMTP Error: Could not connect to SMTP host.

    SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport “ssl” – did you forget to enable it when you configured PHP? (1927201591)

    You’ve either got an error with your SMTP settings, or you need to create the address from which you are attempting to send the emails.

    For example, the default ‘from address’ that wordpress uses is ‘wordpress@your-domain.com’

    I would recommend creating that address, changing the ‘from address,’ ensure that your ‘to address’ is an address on the same domain, then test the form again.

    If that works, then you’ve had a problem with the settings on your mail server.

    i was lucky enough to get it working with the “use gmail” checkbox.
    my port changed as well.

    Did everything that was suggested and I’m still getting SMTP errors

    🙁 Sorry I couldn’t help. I don’t know much about email.

    Shouldn’t be this difficult. Sometimes, I find myself trying to fix something more often than blogging

    One thing I noticed is that I can’t change the port number in Configure SMTP

    Ya, screw this. Waste of my time.

    Neither Contact Form 7 or this one works

Viewing 15 replies - 1 through 15 (of 64 total)
  • The topic ‘[Resolved] [Plugin: Contact Form 7] Still doesn't work’ is closed to new replies.
Skip to toolbar