Support » Plugin: Contact Form 7 reCAPTCHA Extension » [Plugin: Contact Form 7 reCAPTCHA Extension] reCaptcha for registered Users

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andre Pietsch



    sorry for my late reply. Some other projects needed my attention.

    That depends on the reCAPTCHA plugin used. If there is the possibility to shut it off for registered users than I will try to consider that option. Maybe I can add an extra option that works like the language and theme option.

    Kind regards,


    Plugin Author Andre Pietsch



    I fully support that option for ‘WP-reCAPTCHA’ and ‘Better WordPress reCAPTCHA’ from version 0.0.12 and later.

    Please try if it suits your needs.

    Kind regards


    Plugin Author Andre Pietsch



    I hope everything is working for you. I would set this to “resolved” if it is OK for you.

    Kind regards


    I tried this plugin with both WP-reCAPTCHA and BWP reCAPTCHA for a registered user.

    When logged in, the recaptcha field is hidden on the web form, but when you attempt to submit the form, you still get validation errors expecting entry of the recaptcha field??

    I am using version 0.0.12.

    Same error occurs when using WP-reCAPTCHA or BWP-reCAPTCHA.

    In WP-reCAPTCHA option Target (under Settings), ticked “Hide for all Registered Users”
    Also tried, ticked “Hide for administrator” – same issues.

    So I don’t think this problem is resolved?

    When the recaptcha field is hidden, is it also removed from the form for registered users?

    Or am I missing something in the configuration??
    Can you please have another look.


    I have the same problem.

    • WordPress v. 3.4.1
    • Contact Form 7 v. 3.2.1
    • Better WordPress reCAPTCHA v. 1.0.1
    • Contact Form 7 reCAPTCHA extension v. 0.0.12


    • Better WordPress reCAPTCHA:
      • This plugin will be:
        • (yes) enabled for comment forms
        • (no) enabled for registration page
      • Hide the CAPTCHA for: (yes) registered users
      • Integrate with Akismet? (yes)

    Contact form: at

    • Form contains: [recaptcha recaptcha-988]
    • Page contains: [contact-form-7 id="21" title="Contact form 1"]

    When I access the form and I am not logged in to WP, I see the captcha field; if I fill in that field and all the other fields correctly, I get:

    “Your message was sent successfully. Thanks.”

    But when I am logged in to WP, the captcha field is not displayed. When I submit the form with equivalent data filled in, it fails with:

    “Validation errors occurred. Please confirm the fields and submit it again.”

    Hi Andre.

    Trying to use the plugin, but the problem as described above is still not solved:
    When I try to send a message when I am logged in, I still get the validation error.
    I use the following plugins:
    Contact Form 7
    Contact Form 7 reCAPTCHA extension

    I also tried Better WordPress reCAPTCHA, but this has the same result.

    WordPress version 3.4.1, so also up-to-date.

    Please have a look into this issue again. For the time being, all visitors will have to be bothered by a captcha, which is still better than eternal error messages. For the rest, it all works like a charm.

    Sorry, forgot to include a link to the page:

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Contact Form 7 reCAPTCHA Extension] reCaptcha for registered Users’ is closed to new replies.