Contact Form 7 reCAPTCHA Extension
[resolved] Newb question (4 posts)

  1. jhauer
    Posted 4 years ago #

    I feel really foolish. I must be missing something. I have tried both WP reCAPTCHA and the "Better" plugin to no avail. I activate the plugins, then go to my CF7 form. I generate a tag for reCAPTCHA. Copy and paste the [recaptcha ...] code into the form and save. I do not get a captcha on my form. What am I missing?


  2. tjohare
    Posted 4 years ago #

    I'm using both myself in my site:

    Because I'm neurotic (just ask my wife), I'd start fresh and re-install both plugins. Then:

    1. Go to the BWP reCAPT page and re-add the pair of API keys which you get from here: https://www.google.com/recaptcha/admin/create
    2. Remember also that the default setting in the plug has Hide the CAPTCHA for registered users (even without any capabilities) checked. Hence logged into the wordpress dashboard makes it invisible
    3. Regenerate the recaptcha key (ie. <p>[recaptcha recaptcha-XXX]</p>) and add to the form and save.

    The easiest way to double check is try in another browser (I typically code in Firefox but view in Internet Exploder for viewing because if it looks decent there, you're Golden).

  3. jhauer
    Posted 4 years ago #

    Thank you! I never thought about the captcha being hidden from registered users! That was it, user error as I suspected.

  4. tjohare
    Posted 4 years ago #

    Don't forget to resolve the thread.

    see the This topic is "not resolved" pulldown box. Change that to resolved and click Change button to the right.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7 reCAPTCHA Extension
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic