Contact Form 7
Really Simple Captcha not working on Contact 7 form (13 posts)

  1. tgrblogger
    Posted 5 years ago #

    I asked this question in the How-To & Troubleshooting forum two days ago, and have yet to receive a reply. Typically I don't post in more than one area, but I really need an answer on this one. So please forgive the double posting if you can.

    I've upgraded to WP 3.0.1 and I'm having issues with the captcha image not displaying properly on the form (using latest plugins of Really Simple CAPTCHA & Contact Form 7). It shows a broken image, and when I view the source, it gives the correct URL to where the captcha image is stored. I have verified that it uses the upload path in settings->media, which is where it is located in the WP 3.0.1 admin dashboard, and that the folder permissions are set properly. I have also confirmed that both the gd library and freetype are compiled with my php install.

    Are there any other conditions that may be causing this? Is the plugin simply not compatible with the current 3.x version of WordPress?

  2. Takayuki Miyoshi
    Plugin Author

    Posted 5 years ago #

    Can you show the URL of the contact page?

    Both Really Simple CAPTCHA and Contact Form 7 are compatible with WordPress 3.x completely as long as I know.

  3. tgrblogger
    Posted 5 years ago #

    Takayuki Miyoshi,
    I apologize for taking so long to reply. The contact form is at: http://johnniesclub.com/contact-us

  4. Takayuki Miyoshi
    Plugin Author

    Posted 5 years ago #

    => Error 404 - Not Found

  5. bigmoose
    Posted 5 years ago #

    I've got the same on a client page here - http://www.worldsportgroup.com/contact-us/

  6. korniholio
    Posted 5 years ago #

    I'm quite sure that it's smthg simple, but I too can't figure out why the uploads folder is writable, the image files for the captcha ARE there, the url path is ok, but they're not showing up. When I go to the url path to the image, I get a 404..

    If someone has a solution, please do explain!

  7. korniholio
    Posted 5 years ago #

    hm.. it was a dumb problem.. seems there was an old .htaccess file in the uploads folder, which has to be removed..

  8. sambovda
    Posted 5 years ago #

    good morning all,

    I use wp mu, Contact Form 7 and Really Simple CAPTCHA, but also User Access Manager (UAC) plugin that's created a htaccess and htpasswd file in wp-content\uploads.

    Unfortunately Really Simple CAPTCHA has created a directory in same upload dir, so images captcha are not displayed!

    How I can change htaccess?

    This is the htaccess content:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteRule (.*) /index.php?uamfiletype=attachment&uamgetfile=$1 [L]

    Thanks everyone!

  9. sm@ug
    Posted 5 years ago #


    bigmoose I can see on your website that you've solved captcha problem.
    Can you please tell us how have you done it?

    I have the same problem and I can not fing an answer..


  10. jjwright85
    Posted 5 years ago #

    Not sure if this will help for everyone, but I was able to fix the broken images by recreating the wpcf7_captcha folder found within the uploads folder. I then applied read/write permissions to it and it started working.

    Seems like the automatically created folder had issues (noticed it wouldn't let me change permissions on it so I deleted it).

  11. I'm having the same problem, and after reading the above responses, I think that the captcha started having issues after I installed Bulletproof Security, which re-writes the .htaccess file and locks it down.

    I'm not a code-person. Can anyone tell me what I might add to the current .htaccess file to enable Really Simple Captcha?


  12. lykzabet
    Posted 5 years ago #


    Yes I'm having a similar problem and I'm no coder either, some or any help much appreciated. I have read as much as and done plenty of research to no avail.

    I can only guess that since both RSC Version 1.2 and CF7 Version 2.4.5 were working perfectly on WP 3.1.1 and then started to fail with shortly after an upgrade to WP 3.1.3 - Though i have my doubts because the error I'm getting that randomly appears on my site is :-

    Warning: imagettftext() [function.imagettftext]: Could not read font in C:\Inetpub\vhosts\my domain\httpdocs\wp-content\plugins\really-simple-captcha\really-simple-captcha.php on line 105

    I then thought it may be a GD - Truetype library issue but once again why when it was working fine earlier?

    Any constructive advice taken with great gratitude thankyou.

  13. Virtuallaw
    Posted 5 years ago #

    I had the same problem.
    Write permissions at \wp-content\plugins\really-simple-captcha\tmp\ solved the problem.

    No it didn't. Sry.
    But deleting and reinstalling the really-simple-captcha plugin did the job.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic