Support » Plugin: Contact Form 7 Phone Module » [Plugin: Contact Form 7 Phone Module] No phone number received in email

  • Resolved popwireless

    (@popwireless)


    Two issues:

    1. The phone number area code field allows only TWO digits. The third digit falls behind the parentheses.

    2. After adding the code to the form I tested it. The phone number was no where to be found in the received email.

    the form:

    <p>Your Name (required)
    [text* your-name] </p>

    <p>Your Email (required)
    [email* your-email] </p>

    <p>Your Phone
    [phone your phone number] </p>

    <p>Subject
    [text your-subject] </p>

    <p>Your Message
    [textarea your-message] </p>

    <p>[submit “Send”]</p>

    http://wordpress.org/extend/plugins/contact-form-7-phone-mask-module/

Viewing 2 replies - 1 through 2 (of 2 total)
  • When field completed the phone number looks like this:

    (41)0555-1212

    I noticed that are are dashes missing between your phone number. I added those to see if that fixes anything and will try another test.

    Plugin Author Gabriel Reguly

    (@gabriel-reguly)

    Regarding version 1.0.4:

    1. Phone mask is hard coded at file jquery.maskedinput-1.3.1.js, future version will address this and allow users to set some options.

    hard coded options are (99) 9999-9999 and (11)999-999-999

    you can edit the file to change it to (999) 999-9999, which seems to be what you are looking for.

    2. There is some extra spaces at your field definition, CF7 needs them to have no spaces, e.g,

    [phone your phone number]

    should be

    [phone your-phone-number]

    Use [your-phone-number] at mail template to get the content of telephone field

    Future version will have an option to generate the tag.

    Regards,
    Gabriel

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Contact Form 7 Phone Module] No phone number received in email’ is closed to new replies.