WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Contact Form 7] On clicking submit no validation or sending occurs

[Plugin: Contact Form 7] On clicking submit no validation or sending occurs

  • boogywonderland
    Member

    @boogywonderland

    I have recently inherited a WordPress site (v3.1) using Contact Form 7 (v2.4.4). During testing I discovered that the contact form does not appear to work on Safari or Chrome; on clicking Submit, the gif loads but no validation or sending occurs and no error appears to be raised. I then asked a large group of friends to test as well and the majority experienced the same on a wide variety of browsers including but not limited to IE 6/7/8, FF, Chrome and Safari.

    Since this is a very popular plug-in with a wide userbase I can only presume that there is something wrong in our configuration here. Please find the config code below. I have also disabled virtually all plugins to no avail.

    I personally have no problems locally with IE8 and FF 3.6.13 on Windows 7. This is a huge issue for the people I am volunteering for, primarily since an error is never raised users may presume the form has been submitted when it has not.

    Could anyone offer any advice?

    Thanks,

    Simon

    `
    [huge chunk of code moderated – please use pastebin.com]
    `

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 4 replies - 1 through 4 (of 4 total)
  • boogywonderland
    Member

    @boogywonderland

    Apologies, the dropdowns are quite extensive! Code can be found here:
    Form

    Plugin Author Takayuki Miyoshi
    Participant

    @takayukister

    boogywonderland
    Member

    @boogywonderland

    Thanks for the response! I’d been through the FAQs and checked with firebug and an XHTML validator and other than a couple of missing images (now fixed) and my predecessors liberal use of the obsolete valign/align attributes in tables, all seems okay. From what I can see the problem is that a request is issued but a response is never received.

    boogywonderland
    Member

    @boogywonderland

    Right, for the sake of my sanity I have been through and fixed all XHTML/CSS errors and the problem is still happening. I am not 100% sure that this isn’t a problem with our host but am not sure what I should be asking them to look at if they are the problem (especially since my Bahasa Indonesia is not great!). Any ideas?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Contact Form 7] On clicking submit no validation or sending occurs’ is closed to new replies.