Support » How-To and Troubleshooting » [Plugin: Contact Form 7] Not sending email

[Plugin: Contact Form 7] Not sending email

  • Hello,

    I am trying to get the contact form to work on my website. I have extracted the files to the plugin directory, activated it and created a new form via the tools menu.

    After saving the form I created a new page called “Contact Us” and pasted the following into it:

    [contact-form 1 "Contact Us"]

    I then tried to leave a comment for myself but it gives the error “Failed to send your message. Please try later or contact administrator by other way.”

    Is there something I am missing? Everything looks great, I can see the fields, my akismet key is working and I typed out a message that shouldn’t look like spam and it still gives the red block.

Viewing 15 replies - 16 through 30 (of 43 total)
  • So did this post get an answer or not?
    Im having the send mail function error message.

    address rejected: Relay access denied in E:\domains\t\theblowout.co.uk\user\htdocs\wordpress\wp-content\plugins\easysms\register.php on line 101
    Something went wrong. Please contact the administrator.

    this is happening on lots of plugins and widgets.

    can anyone help?

    guy my code is like this

    Your Name (required)
    [text* your-name akismet:author]

    Your Email (required)
    [email* your-email akismet:author_email]

    [text your-subject]

    File Upload

    [file file-919]
    Select Your Country

    <select name=”your-country”>
    <option value=”Japan”>Japan</option>
    <option value=”United States”>United States</option>
    <option value=”Canada”>Canada</option>
    <option value=”China”>China</option>
    <option value=”India”>India</option>
    <option value=”other”>other</option>

    Your Message
    [textarea your-message]

    [submit “Send”]

    but its not sending COUNTRY together in the mail.

    any suggestions

    how do i display additional tags on contact 7

    I also have problem with send information via contact form. The red box always says “Failed to send your message. Please try later or contact administrator by other way.”
    Any ideas?

    Below is my code:
    Your Name (required)
    [text* your-name akismet:author]

    Your Email (required)
    [email* your-email akismet:author_email]

    [text your-subject]

    Select Your Country

    <select name=”your-country”>
    <option value=”United States”>United States</option>
    <option value=”China”>China</option>

    Your Message
    [textarea your-message]

    [submit “Send”]

    I can’t get the form to work.

    It appears to be installed correctly, but when I try to test it I get the green spinning arrows and no email is ever sent.

    My site is located at http://www.leave-the-job-behind.com/

    I really need to get this fixed ASAP.

    Thanks to anyone who can help…!

    My code –
    <p><b>Name:</b> (required)
    [text* your-name 20/] </p>

    <p><b>Your Email:</b> (required)
    [email* your-email 20/] </p>

    <p><b>Phone:</b> (required)
    [text* Your-phone 20/] </p>

    <p>[submit “Send”]</p>


    I’m having the same problem.

    I have followed the instructions in the readme file and checked the FAQ but I can’t get the form to send email.

    I have installed WP on a Linux server, shared hosting.

    I have deactivated all other plugins.

    You can see the form at http://www.wynnum.com.au/?page_id=27

    Thanks for the help.

    I’m a newbee in WP, This is the first time I use WP and contact form 7 but I con not send mail.

    It’s always note:”Failed to send your message. Please try later or contact administrator by other way.”

    This is my form: http://werte-funkimmobilien.de/demo/?page_id=76

    And here is info in cf7-admin:
    From:Nguyen Ngoc Anh <ricky.nguyen@queenb.vn>
    Subject:Test mail

    Any suggestions ??


    Even, I just make a simple page to test mail. It can not work, too.

    It’s here

    Hi Ricky,

    I see you sent me a test message from my contact form. I couldn’t wait for the reply on this forum so I have used another plugin. I’m still waiting for an answer on this question.

    This is really frustrating, I can only receive messages to my private email address which is not on the same domain a my workdpress hosted site. Any body have a solution for this??


    I have just installed Contact Form 7 today, and was testing out my form. However, i tried two different emails addresses, and both of them did not receive the testing email. I noticed from this forum, many have the similar problem. Did any of you get it fix? If so, please direct me on the right way. Thanks in advance


    Hi all, good news for… some
    after going through some research… you want to make sure your server allows php mail() function. some of the server (the one i used, webfaction) do not allow that, they uses SMTP instead. thus, you need to install additional plug-in (the one i use is WP Mail SMTP) after configuration, go into your email plugin and double check if all the php mail() function is using wp_mail() instead. after that… it works wonderfully

    cheers guys

    Yes! correctly!

    I’m in the same boat with many of you. I’m getting the red box of death. I have the latest WP and Contact Form 7. WP is hosted on Yahoo Small Biz. It said I had to setup PHP Mail for the function to work which was nothing more than setting a default user (defaultuser@mydomainname.com). It said the name was accepted. I’ve tried all of the above Contact suggestions like adding the label tag. Nothing seems to work. I’m afraid it’s something over my head in the bowels of the php code somewhere but hopefully it’s simpler. I also added email specs under WP settings/writing but not sure if I did that correctly (no real documentation that is not overly hypothetical). Anyway, anybody have a Yahoo hosting situation where they got this to work or just any other suggestions?

    SOVLED. If nothing else works for you, this will: http://www.roblayton.net/archive/wordpress-not-sending-emails-anymore-solved/

Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘[Plugin: Contact Form 7] Not sending email’ is closed to new replies.
Skip to toolbar