WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Contact Form 7] Form submits but no email is received

[Plugin: Contact Form 7] Form submits but no email is received

  • jennyharward
    Member

    @jennyharward

    Everything seems to be working great, and when you submit the form it says it was submitted successfully. The problem is no emails are ever received. I have even changed the email address a few times to make sure that it isn’t the problem. Have I set it up wrong? Where else is the recipients email address specified?

    <p>Your Name (required)
    [text* your-name] </p>

    <p>Your Email (required)
    [email* your-email] </p>

    <p>Subject
    [text your-subject] </p>

    <p>Your Message
    [textarea your-message] </p>

    <p>Please enter the text below:
    [captchac captcha-809 size:m]
    [captchar captcha-809]</p>

    <p>[submit “Send”]</p>

Viewing 15 replies - 1 through 15 (of 15 total)
  • Kanashimi
    Member

    @kanashimi

    Exact same problem. Had Contact Form 7 installed for almost a year, and suddenly not receiving any e-mails.

    so am I.

    It only work if I use an email with my own domain.

    Like @website.com

    need help

    Same here… 🙁

    For me, it looks like the problem began after updating from 3.0.1 to 3.0.4. And it does NOT work with my own domain or anyone else’s.

    I’m not a techie, so I don’t have a clue how to fix it. I hope this info helps some braniac out there find a cure.

    Thanks!

    no way to make the plugin work.

    I receive an empty email whose sender is “syntax error”.

    I tried another Contact Form (sorry, just need to find an answer), but it didn’t work either. Then I found this post dated 2/2/11 – pretty recent.

    Contact Form not Sending Emails

    Haven’t tried it yet (because I’m not very techie) but I’m trying to figure it out. If anyone else has success, I’d love to hear about it.

    Thanks!

    johnl123d
    Member

    @johnl123d

    Same here. Contact form 7 was working perfectly fine for me before. Suddenly it just stops working on all my sites. I get the message it was submitted successfully, but I receive no emails at all.

    I tried several times, still no emails. This is very bad for my sites, since people can’t contact me.

    @tregman

    I’ve checked all 3 possible things mentioned in this post you linked to us. it is still not working for me.

    I am not a techie too, but it’s not hard to do. All you need is netbeans and filezila.

    don’t know what to do. =/

    johnl123d
    Member

    @johnl123d

    Just out of curiousity, which hosting company are you guys using. I am using godaddy and it seems that this may be a hosting problem.

    I’m having the same problem, both on my local machine and on a Bluehost install of WP. All Contact Form 7 forms were working fine, now they’re all busted. Hrm.

    Kanashimi
    Member

    @kanashimi

    I have a feeling this is directly assigned to BlueHost. Their support is quoted as such:

    “I wasn’t able to see a “from address” on that email header information. Months ago we made a change to our system that forces all email sent from our customer accounts to be checked for spoofing. Due to this measure, you can no longer send emails that appear to be from an email address that is not on your account.

    Therefore, if you have a contact form or email program that attempts to set the “From:” header to anything but an email address that exists in your bluehost account, the mail will be rejected by our spoofing filter.

    If you are sending email through SMTP, you must connect to “localhost” to send your email. Remote SMTP connections are no longer allowed from our servers and you must use AUTH when you connect to the SMTP.

    Lastly, there is only one other change you should be aware of. Our mail system will not allow this header:

    From: email@domain <email@domain.com>

    Even if the email is valid, our system will fail the message due to the double declaration of the email address.

    Please check your script and ensure that these requirements are being met by your script. If you feel that your script meets these requirements and it’s still failing, we will be happy to examine it for you. Please just provide the script code and a way to test the issue so we can troubleshoot.”

    For if this can help anybody, I had a similar problem and it’s solved.

    Contact Form 7 sayed mail was sended ok, but nothing was received.

    I discovered by chance – as I intended to create a new form from the admin dashboard – that fields in the form 1 must be fill in, and mine were empty.

    Now, it works ok.

    I found a answer but I dont know how to make it work till now.

    My host, a brazilian company (Im brazilian) blocks every single message that doesnt have the field “from” “Return-Path” and “Reply-To” as they understand it as spam.

    I think the easy thing to do is change my host service.

    Fabio Palenzuela
    Member

    @fabio-palenzuela

    I have more than one form… perhaps because it doesn’t work?
    Has anyone managed to solve this problem?

    Hi,

    I made a form and it worked perfectly.
    Next day it still works except the mail2 part.

    I have uninstalled it, re-installed it but I can’t get the mail2 part to work again. Even tried it with the standard form, not working.

    Does anyone has a solution?

    Karfil

    Bozz
    Participant

    @bozzmedia

    Kanashimi is correct, you have to setup the Mail settings correctly for it to pass Bluehost spoofing filters.

    I have elaborated on the fix here:
    http://www.bozzmedia.com/web/posts/how-to-fix-contact-form-7-with-wordpress-3-2-on-bluehost/

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Contact Form 7] Form submits but no email is received’ is closed to new replies.