WordPress.org

Forums

Contact Form 7
[resolved] Form POST request not being answered when submitting a form (5 posts)

  1. amereservant
    Member
    Posted 4 years ago #

    This plug-in was working fine in one of the previous versions, but after one of the updates, forms are no longer being submitted.

    The loading arrows continue to spin indefinitely and when I checked the request with FireBug, the POST request is never answered for some reason.
    I disabled all other plug-ins, switched to the default "Twenty-Ten" theme and still the exact same thing.

    The POST parameters *seem* correct, so I'm at a loss as to why it's not working.
    Here's what parameters are being submitted:

    _wpcf7    3
    _wpcf7_captcha_challenge_captcha-684    1084281957
    _wpcf7_is_ajax_call    1
    _wpcf7_unit_tag    wpcf7-f3-p49-o1
    _wpcf7_version    2.4.1
    captcha-684    9EQ7
    your-email    myemail@gmail.com
    your-message    123456
    your-name    David
  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 4 years ago #

    Can I see the contact page? (URL?)
    What version of WordPress are you using?
    What is your web server? Apache? IIS?
    How is your .htaccess setting?
    What plugins are you using with Contact Form 7?

  3. amereservant
    Member
    Posted 4 years ago #

    The URL I have the form coming to my email address is http://thatchurch.com/highlander/, but the other forms aren't working either.

    I'm using WordPress 3.0.1

    Apache for the web server on a Linux OS.

    The .htaccess settings are:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    As far as plug-ins go, I disabled everything except Contact Form 7, then enabled just Really Simple CAPTCHA in addition, but still no luck. The plug-ins I have installed are these:

    • Blip.TV Manager - A plug-in I wrote and it wouldn't interfere with it.
    • Lightbox Plus
    • Meta SEO Pack
    • NextGEN Gallery
    • Really Simple CAPTCHA
    • TinyMCE Advanced

    Nothing new has been added except updates I've made to my Blip.TV Manager plug-in and I've tried completely removing it and it doesn't effect (and shouldn't anyways) the Contact Form 7.

    The thing that gets me is there's NO response whatsoever to the POST request, yet AJAX works everywhere else just fine.

  4. amereservant
    Member
    Posted 4 years ago #

    Hey,
    Nevermind on this issue. It appears there was some sort of problem with my email hosting and the emails were backed up and not being sent. I would recommend adding some sort of functionality to give a response if the sending email function(s) fail or take too long.

  5. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 4 years ago #

    That's good to hear.

    I would recommend adding some sort of functionality to give a response if the sending email function(s) fail or take too long.

    I agree. When the mail function fails you'll see the error message, but there is nothing when it takes too long. Please tell me if you have good idea to implement this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic