[Plugin: Contact-Form-7] File Upload Failing (5 posts)

  1. InHouse
    Posted 4 years ago #


    I have a Contact Form 7 form on a testimonials page of a website that works perfectly, unless I try to upload an image that is larger than 1mb. I have upped the max size to 3mb and the upload still fails saying "Failed to send your message. Please try later or contact the administrator by another method". I read a lot of other forum threads and none seem to figure out my problem. I tried using "3mb" and also converting to bytes with no difference. Files under 1mb upload just fine but a photo exactly 1mb fails regardless of my max file size. Host max file size is 10mb.

    Also, I have "Contact Form to DB Extension" plugin that saves the submissions to the database. Even though the email send fails, the submission actually saves to the database! I am completely boggled.

    Thanks for any help.

    [file file-upload id:file-upload limit:4mb filetypes:gif|png|jpg|jpeg]

    WP version 3.2.1 and Plugin version 3.0

  2. Takayuki Miyoshi
    Posted 4 years ago #

    This situation shows that you can upload up to the limit setting (4mb), but you can't send mail attached with the large files. I guess your host has limitation setting to the attachable max file size.

  3. InHouse
    Posted 4 years ago #

    Thanks for your reply @Takayuki Miyoshi, but I have tested this theory by emailing the same photo to myself with success. I don't believe this to be the problem. The plugin gives the error message so wouldn't the issue lie with the plugin code/settings?

  4. InHouse
    Posted 4 years ago #

    Just confirmed with the host again that the upload limit is 10mb. He also increased the memory limit to 51mb in php.in file. Still doesn't send a 1mb photo. Same error message. I also deactivated the Contact Form to DB Extension plugin to make sure that wasn't somehow interacting with the form negatively. That didn't help either.

    Anyone have another suggestion?

  5. InHouse
    Posted 4 years ago #

    I tried moving the php.ini file from the root of my site to the root directory of the install and that hasn't worked either. I am about to uninstall the entire plugin I'm so frustrated.

    Current settings.

    ; Resource Limits ;
    max_execution_time = 300     ; Maximum execution time of each script, in seconds
    max_input_time = 60	; Maximum amount of time each script may spend parsing request data
    memory_limit = 200M
    post_max_size = 100M
    upload_max_filesize = 51M

Topic Closed

This topic has been closed to new replies.

About this Topic